Project

General

Profile

Actions

Bug #14919

closed

OpenVPN forms invalid ``route`` statements for empty local networks

Added by aleksei prokofiev 6 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
24.03
Release Notes:
Default
Affected Version:
Affected Architecture:
All

Description

If I specify IPv4 Local networks in OpenVPN server and leave comma in end of the list, in config will be presented push "route 0.0.0.0"

In config
push "route 192.168.168.0 255.255.255.0"
push "route 10.0.0.0 255.255.255.0"
push "route 0.0.0.0"

If delete a trailing comma, all will be as expected
push "route 192.168.168.0 255.255.255.0"
push "route 10.0.0.0 255.255.255.0"


Files

clipboard-202310252000-gfdgr.png (19.8 KB) clipboard-202310252000-gfdgr.png aleksei prokofiev, 10/25/2023 05:00 PM
Actions #1

Updated by Jim Pingle 6 months ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from OpenVPN to OpenVPN
  • Target version set to 2.8.0
  • Affected Plus Version deleted (23.05.1)
  • Plus Target Version set to 24.03

It should trim/ignore any empty entries like that, but it may not be catching that case properly.

Actions #2

Updated by Jim Pingle 6 months ago

  • Subject changed from OpenVPN incorrect validation of config to OpenVPN forms invalid ``route`` statement for empty local networks
Actions #3

Updated by Danilo Zrenjanin 6 months ago

  • Status changed from New to Confirmed

I can replicate the issue on the:

23.05.1-RELEASE (amd64)
built on Wed Jun 28 03:57:27 UTC 2023
FreeBSD 14.0-CURRENT
Actions #4

Updated by Lev Prokofev 6 months ago

Can reproduce it on BETA

23.09-BETA (amd64)
built on Mon Oct 23 20:01:00 MSK 2023
FreeBSD 14.0-CURRENT

With comma, the server config contains:

push "route 192.168.4.0 255.255.254.0"
push "route 172.30.0.0 255.255.255.0"
push "route 0.0.0.0"

Actions #5

Updated by Danilo Zrenjanin 4 months ago

Tested against:

23.09.1-RELEASE (amd64)
built on Wed Dec 20 18:27:00 UTC 2023
FreeBSD 14.0-CURRENT

I am able to replicate the issue.

Actions #6

Updated by aleksei prokofiev 3 months ago

Tested on
24.03-DEVELOPMENT (amd64)
built on Fri Jan 26 9:00:00 MSK 2024
FreeBSD 15.0-CURRENT

The issue still presented.

Actions #7

Updated by Jim Pingle about 1 month ago

  • Assignee set to Jim Pingle
Actions #8

Updated by Jim Pingle about 1 month ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100
Actions #9

Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Can't reproduce it on a current snapshot now, so it appears the fix is working as expected.

Worth noting this affected anything that generated OpenVPN route statements, not just that one field.

Actions #10

Updated by Jim Pingle about 1 month ago

  • Subject changed from OpenVPN forms invalid ``route`` statement for empty local networks to OpenVPN forms invalid ``route`` statements for empty local networks
Actions

Also available in: Atom PDF