Project

General

Profile

Actions

Bug #14967

closed

Cannot disable Router Advertisements when the interface IPv6 configuration is set to ``None``

Added by Kevin Murray 4 months ago. Updated 23 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPv6 Router Advertisements (radvd/rtsold)
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
24.03
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:
All

Description

Background: This is a Netgate XG-7100-1U box ordered in June 2019. It is setup as a pretty standard 1 WAN, 1 LAN firewall, and originally was done through the default setup at the time. The software has been updated pretty religiously and currently is on the most stable version of PFSense+, 23.09. I have never used / configured IPv6 on this box to my knowledge.

Issue/Bug: I was trying to make a change to our LAN interface. Specifically I was trying to change the Switch Port which wasn't set. When I made the change and hit "Save", I get the following error _ "The Router Advertisements Server is active on this interface and it can be used only with a static IPv6 configuration. Please disable the Router Advertisements Server service on this interface first, then change the interface configuration."_

Our LAN is configured with IPv4 Configuration Type set to "Static IPv4" & IPv6 Configuration Type set to "None".

When I went to Services -> Router Advertisement, to try to turn off Router Advertisement, I get the following error: "Router Advertisements can only be enabled on interfaces configured with a static IPv6 address. This system has none."

The only way I was able to fix this was to temporarily change IPv6 Configuration Type to "Static IPv6", set a valid IPv6 address for the LAN, then goto Services -> Router Advertisement and set the Router Advertisement Mode to "Disabled". Then disable IPv6 on the WAN.

Unfortunately, I can not post any screen captures as I didn't think to take any at the time I was experiencing this issue, and now that I was able to work around it, I can't go back & recreate it.


Related issues

Related to Bug #11527: Bugs on pfsense 2.5.0Rejected02/20/2021

Actions
Related to Bug #12486: Editing a network interfaceNot a Bug

Actions
Actions #1

Updated by Kris Phillips 4 months ago

I can confirm this bug. You can also work around it by setting the LAN interface to "Track Interface" and setting it to track the upstream WAN interface. This will restore the Router Advertisement menu to allow you to disable it. This issue was also present on 23.05.1 and possibly earlier, so it's not new in 23.09.

Actions #2

Updated by Jim Pingle 4 months ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from IPv6 Router Advertisements (RADVD) to IPv6 Router Advertisements (radvd/rtsold)
  • Target version set to 2.8.0
  • Affected Plus Version deleted (23.09)
  • Plus Target Version set to 24.03
Actions #3

Updated by Marcos M 4 months ago

  • Related to Bug #11527: Bugs on pfsense 2.5.0 added
  • Related to Bug #12486: Editing a network interface added
Actions #4

Updated by Marcos M 4 months ago

  • Subject changed from Can't change any settings in LAN Interface due to IPv6 & Router Advertisements Server service which also can't be changed to Cannot disable Router Advertisements when the interface IPv6 config is set to ``None``
  • Status changed from New to Pull Request Review
  • Assignee set to Marcos M
  • Affected Version set to 2.5.0
  • Affected Architecture All added

https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/1102

Apply the following fix with the System Patches package: Show

Actions #5

Updated by Jordan G 3 months ago

above patch seems to be effective on 23.09, prevents being caught in a loop of no IPv6, cannot disable RA, rinse, repeat

Actions #6

Updated by Marcos M 3 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #7

Updated by Marcos M 2 months ago

  • Status changed from Feedback to Resolved
Actions #8

Updated by Jim Pingle 23 days ago

  • Subject changed from Cannot disable Router Advertisements when the interface IPv6 config is set to ``None`` to Cannot disable Router Advertisements when the interface IPv6 configuration is set to ``None``
Actions

Also available in: Atom PDF