Project

General

Profile

Actions

Bug #2332

closed

gateways always renamed to "dynamic". Implement proper IPv6 support

Added by Seth Mos over 9 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Gateways
Target version:
Start date:
04/01/2012
Due date:
% Done:

90%

Estimated time:
1.50 h
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

When a dynamic IPv6 type is specified all gateways will be tagged "dynamic".

Trying to modify an existing static v4 gateway is impossible and always changed to "dynamic".
The config.xml shows that it appears that just the description is changed to dynamic.

Resolve this by implementing address families in the gateway edit page "ipproto" inet/inet6.
Compare these when performing the dynamic check.
Do not allow changing address families after a entry is made. Allow deletion.

Actions #1

Updated by Seth Mos over 9 years ago

Ok, so I now name the dynamic gateways by their config type, Jim uncovered a few corner cases and I'll look into whatever config upgrade code would be required so that gateway groups still work.

Actions #2

Updated by Seth Mos over 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90
  • Estimated time set to 1.50 h
  • Affected Version set to 2.1

Upgrade code checked in that I tested by upgrading a 2.0 vm with 3 dynamic wans, it upgraded accordingly but might need more variations to be certain.

Actions #3

Updated by Jim Pingle over 9 years ago

This seems mostly OK but I discovered one case the other day that is still problematic.

If you have a PPPoE interface, and a custom gateway for that PPPoE interface (In my case, a custom name and custom loss/delay timings), it's possible when the PPPoE link is reconnecting for the dynamic counterpart (e.g. OPT1_PPPOE) to show up as well as the custom one, so it would appear for a short time that there were two gateways on the interface.

Actions #4

Updated by Renato Botelho over 8 years ago

  • Status changed from Feedback to New
Actions #5

Updated by Ermal Luçi over 8 years ago

  • Status changed from New to Feedback

This seems the same root cause as #2910

Actions #6

Updated by Chris Buechler about 8 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF