Project

General

Profile

Actions

Bug #2349

closed

vlan(4) needs altq adaption on FreeBSD 8.3++

Added by Ermal Luçi over 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
04/06/2012
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

The vlan(4) code has been put to use if_transmit interface on 8.3 and up of FreeBSD and a solution needs to be found for altq(9).

This will break a lot of configurations with shaping out there if not fixed.

Actions #1

Updated by Mark Uhde over 9 years ago

Now that the traffic shaper itself is fixed, this is the bug I run up against, LOL. Thanks for your hard work Ermal! I can confirm that this still affects the latest snapshots, and if any testing needs done, I'm here to try anything.

Actions #2

Updated by Cino . over 9 years ago

Any update on this issue? I haven't tried since it was reported broken.. Its a show stopper for me to update freebsd 8.3..

Apr 6 07:53:55 php: : There were error(s) loading the rules: pfctl: em0_vlan5: driver does not support altq - The line in question reads [0]:
Apr 6 07:53:55 php: : New alert found: There were error(s) loading the rules: pfctl: em0_vlan5: driver does not support altq - The line in question reads [0]:
Apr 6 07:53:53 php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'pfctl: em0_vlan5: driver does not support altq'

Actions #3

Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Feedback

For 2.1 this is solved in newer snapshots.
During transition to 9 this will be solved in more generic way.

Actions #4

Updated by Cino . over 9 years ago

I'll test this out sometime in the next 2 weeks and report back

Actions #5

Updated by Mark Uhde over 9 years ago

Working great for me now, thanks Ermal for your hard work!

Actions #6

Updated by Seth Mos over 9 years ago

  • Status changed from Feedback to New

This patch broke ARP on a VLAN for directly connected devices. E.g. the switch IP address.

You can communicate with devices on the VLAN, but not the switch address. I and another customer have already run into that issue. We'll revert this patch and look for a better fix.

Actions #7

Updated by Chris Ogden over 9 years ago

Tried updating to the latest snapshot tonight and immediately noticed issues related to the ARP on a VLAN. Looking to see if any progress has been made on this offline, really wanted to move up from the May snapshot I have been running.

Thanks for your hard work.

Actions #8

Updated by Anonymous almost 9 years ago

Hi there. Seems the problem is back. I've just upgraded the 1947 build snapshot (Wednesday, December 5th 2012) and got that error :

"There were error(s) loading the rules: pfctl: em1_vlan5: driver does not support altq - The line in question reads [0]: ]"

Any hint on how to fix it?

Many thanks for all the hard work done around here!

Actions #9

Updated by Anonymous almost 9 years ago

wifiste . wrote:

Hi there. Seems the problem is back. I've just upgraded the 1947 snapshot build (Wednesday, December 5th 2012) and got that error :

"There were error(s) loading the rules: pfctl: em1_vlan5: driver does not support altq - The line in question reads [0]: ]"

Any hint on how to fix it?

Many thanks for all the hard work done around here!

Actions #10

Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

Patch has been committed and will be present on newer snapshots.

Actions #11

Updated by Ermal Luçi almost 9 years ago

  • % Done changed from 0 to 100

Applied in changeset pfsense-tools:commit:b983c67530b9d8beaf6d37d9a1d842b68ff24bba.

Actions #12

Updated by Chris Ogden almost 9 years ago

I am not getting the driver does not support altq error but I can't ping across my vlans anymore. Devices on each vlan can get out to the internet, but each vlan can still get to the internet. I also can't communicate to other vlans via SSH, HTTP, etc. This occurred after updating to the latest snapshot tonight. If additional information is needed, I can provide that. All NICs are Intel

Actions #13

Updated by Chris Ogden almost 9 years ago

Chris Ogden wrote:

I am not getting the driver does not support altq error but I can't ping across my vlans anymore. Devices on each vlan can get out to the internet, but not to each other. I can't communicate to other vlans via SSH, HTTP, etc. This occurred after updating to the latest snapshot tonight. If additional information is needed, I can provide that. All NICs are Intel

Actions #14

Updated by Chris Ogden almost 9 years ago

Please ignore my reported troubles, see http://forum.pfsense.org/index.php/topic,58717.0.html for an explanation.

Ermal - Thanks for your great work, I will try traffic shaping later this week but I have confidence your fix will work on my configuration as well.

Actions #15

Updated by Ermal Luçi almost 9 years ago

So can you confirm it works correctly now?

Actions #16

Updated by Chris Ogden almost 9 years ago

I can confirm that this patch did not break vlan support as it did 8 months ago.

I had to completely rebuild my pfsense and configuration to confirm that, I haven't tried the traffic shaper yet as the reload put me behind schedule. I hope to test that sometime this week.

Actions #17

Updated by Phil Lavin almost 9 years ago

Can anyone speculate on if this will fix the same error with sk1_vlan1 or if the fix was only applicable to em* interfaces? If it should work, I'll upgrade and give this a try as it's an issue I'm facing on a couple of week old snapshot.

Actions #18

Updated by Ermal Luçi almost 9 years ago

Its for all vlans not specific to any driver.

Actions #19

Updated by Phil Lavin almost 9 years ago

Upgraded last night - the wizard completed correctly without errors. Nice work :)

Actions #20

Updated by Renato Botelho almost 9 years ago

  • Status changed from Feedback to Resolved
Actions #21

Updated by Andreas Huser over 8 years ago

Hi

i'm sorry for reopening this ticket.
I have four openvpn connections and try to configure a traffic shaper with the wizard.
I configure the shaper with four „Wan“ and select three from them from the openvpn gateways.

Error message:
There were error(s) loading the rules: pfctl: ovpnc2: driver does not support altq - The line in question reads [0]: ...

Thanks a lot
Regards Andreas

Actions #22

Updated by Andreas Huser over 8 years ago

Sorry i use the latest 2.1 RC0 i386 snapshot

Actions #23

Updated by Mark Uhde over 8 years ago

Andreas, that's not really relevant to this bug - this is specifically for making altq work with the VLAN driver, that's related to to OpenVPN driver, not the VLAN driver.

I'd also question the idea of trying to use the traffic shaper on a VPN interface, I'm not an expert by any means, but it seems unlikely to be effective even if the driver did support it.

Actions #24

Updated by Steve Kerrison over 8 years ago

I just updated from a January build to yesterday's build and still get altq errors similar to those above on my lagg0_vlanX interfaces. I assigned an igbX_vlanY iface as well... Same problem. Do I need a fresh install or have I missed something?

Cheers!

Actions

Also available in: Atom PDF