Project

General

Profile

Bug #3249

DHCP Server/DHCP Relay both say the other is started

Added by Hans Kokx over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv4)
Target version:
Start date:
10/03/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1
Affected Architecture:
i386

Description

Under Services > DHCP Server, I get the following message:

The DHCP Server can only be enabled on interfaces configured with static IP addresses.
Only interfaces configured with a static IP will be shown.

DHCP Relay is currently enabled. Cannot enable the DHCP Server service while the DHCP Relay is enabled on any interface.

Meanwhile, under Services > DHCP Relay, I get the following:

DHCP Server is currently enabled. Cannot enable the DHCP Relay service while the DHCP Server is enabled on any interface.

I have several active DHCP leases, and I've rebooted the system (and am still able to obtain a DHCP lease).

2.1-RELEASE (i386)
built on Wed Sep 11 18:16:50 EDT 2013
FreeBSD 8.3-RELEASE-p11

History

#1 Updated by Chris Buechler over 7 years ago

  • Status changed from New to Feedback

short of disabling the input validation or manually editing the config, that should be impossible. Do you have specific steps to replicate on a clean system?

#2 Updated by Hans Kokx over 7 years ago

I've never manually edited the config. For all intents and purposes, this is a relatively clean and simple config -- it's been in place for a couple of years now, and no configuration changes were made prior to upgrading to 2.1 (when this issue arose).

My configuration has two interfaces -- WAN and LAN -- with several firewall rules. DHCPD serves out to my LAN. Aside from that, no other configuration has been done. As I stated before, this is the same configuration I've been doing for years. Everything was fine until 2.1 (and I was hoping 2.1.1 would fix my issues). Now, I'm experiencing this (and a further issue where I can't pass traffic to my gateway, intermittently... but I haven't determined what the cause is, and it's not relevant here).

Would a [scrubbed of personal information] config backup help?

#3 Updated by Jim Pingle over 7 years ago

The scrubbed backup would definitely help. The only way I can see this happening is if there was an interface at one time that had DHCP or relay active and then that interface was removed. Though I thought the current active check for both the dhcp server and relay accounted for that, seeing the config would show us for sure what is going on.

#4 Updated by Hans Kokx over 7 years ago

  • File config-pfsense.home.hadak.org-20131004074223.xml added

Scrubbed config attached.

Sidenote: wasn't particularly thrilled to see my password stored in plaintext all over the file, nor was I expecting to see config for packages that have been removed.

#5 Updated by Jim Pingle over 7 years ago

In your config somehow you managed to get both of them enabled. The DHCP settings for the LAN show it enabled, and the DHCP relay settings show it enabled on LAN at the same time. I'd be interested to know if you can reproduce that from a new/fresh config.

For now, edit the section you don't want out of the unscrubbed config.xml file (such as the <dhcrelay> ... </dhcrelay> section near the very end), and restore the backup.

I tried on a new setup and I can't seem to make it break, if I enable one the other page gets shut down and vice versa. If you can come up with a procedure to reproduce it from a fresh config it would help narrow it down.

Re: Passwords - https://doc.pfsense.org/index.php/Why_are_some_passwords_stored_in_plaintext_in_config.xml%3F
Re: Package config - They have to be kept or else the config would be lost when upgrading/reinstalling a package.

Both unrelated to this bug though.

#6 Updated by Hans Kokx over 7 years ago

I can't explain it, either. I'm not sure if I could duplicate it (and I'm hesitant to restore the config remotely, unless you're certain it will come back up).

I'll edit the config and disable dhcrelay. So very, very strange. Like I said, this only happened after the upgrade. Did something happen during the upgrade procedure itself, I wonder?

OT: Passwords make sense. I was just taken back from it. Didn't realize. Understood on the package config, too. When removing the package manually, is there an option to purge all config?

#7 Updated by Jim Pingle over 7 years ago

Nothing in the upgrade that would have enabled it if it weren't already enabled. We'd need to see a copy of the pre-upgrade config to compare though.

#8 Updated by Hans Kokx over 7 years ago

I pulled the dhcrelay section out of the config and restored from it. That seems to have done the trick. Normally, I'd have kept a backup of the config, but it's eluding me right now. If I find it, I'll try to update this bug in the future.

Thanks for helping sort this out, Jim.

#9 Updated by Hans Kokx over 7 years ago

  • File pfsense-config.xml added

I found that config from before. I've attached it.

#10 Updated by Scott Smith over 7 years ago

i too have found this same problem. My config has been workign for years and I have upgraded to

2.1-RELEASE (i386)
built on Wed Sep 11 18:16:50 EDT 2013
FreeBSD 8.3-RELEASE-p11

not long after the release date. I have been adjusting NTP config and went to change DHCP server settgins in pfsense. I cannot access the DHCP server page:

DHCP Relay is currently enabled. Cannot enable the DHCP Server service while the DHCP Relay is enabled on any interface

DHCPRelay page says:

DHCP Server is currently enabled. Cannot enable the DHCP Relay service while the DHCP Server is enabled on any interface.

I doubt that the DHCP servers settings have change since the update. I may have

My installation is on vsphere 5.x and I have 2.02 and I think 2.03 preupgrade snapshots.

S.

#11 Updated by Renato Botelho over 7 years ago

Scott Smith wrote:

i too have found this same problem. My config has been workign for years and I have upgraded to

2.1-RELEASE (i386)
built on Wed Sep 11 18:16:50 EDT 2013
FreeBSD 8.3-RELEASE-p11

not long after the release date. I have been adjusting NTP config and went to change DHCP server settgins in pfsense. I cannot access the DHCP server page:

DHCP Relay is currently enabled. Cannot enable the DHCP Server service while the DHCP Relay is enabled on any interface

DHCPRelay page says:

DHCP Server is currently enabled. Cannot enable the DHCP Relay service while the DHCP Server is enabled on any interface.

I doubt that the DHCP servers settings have change since the update. I may have

My installation is on vsphere 5.x and I have 2.02 and I think 2.03 preupgrade snapshots.

S.

Is it possible to share the 2.0.x config used just before the upgrade (without relevant data)? This can help us to reproduce the issue

#12 Updated by Chris Buechler about 7 years ago

  • Status changed from Feedback to Closed

none of the upgrade code would do that. The input validation prevents configuring the system in that manner in every possible way I know of. Short of manually editing the config, I don't see any way to make this happen. If someone has a replicable scenario, please post.

#13 Updated by Scott Smith almost 7 years ago

I am not across the update code but the problem definitely occurred. I have just manually edited the server's /conf/config.xml file and found dhcp relay and dhcp server defined. I have now deleted the4 dhcp relay entry. I can now [without reboot] access the dhcp server config web page. This is what was removed:

&lt;dhcrelay&gt;
&lt;interface&gt;lan&lt;/interface&gt;
&lt;server&gt;192.168.1.9&lt;/server&gt;
&lt;enable/&gt;
&lt;agentoption/&gt;
&lt;/dhcrelay
and I still need to find why/what this reffers to in my pre-upgrade server image.

s.

#14 Updated by Jim Thompson over 6 years ago

  • File deleted (pfsense-config.xml)

#15 Updated by Jim Thompson over 6 years ago

  • File deleted (config-pfsense.home.hadak.org-20131004074223.xml)

Also available in: Atom PDF