Project

General

Profile

Bug #3281

In certain cases, GRE interfaces are missing the "RUNNING" flag at bootup and will not function

Added by Jim Pingle over 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Ermal Luçi
Category:
Interfaces
Target version:
Start date:
10/21/2013
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.1
Affected Architecture:

Description

Still trying to gather information but this has been directly observed on a customer system.

GRE tunnel configured and an interface assigned, with IP configured. The gre0 interface is marked "UP" at boot time but it does NOT have the "RUNNING" flag. In this state, the GRE tunnel will not accept nor initiate traffic over the tunnel. If you run "ifconfig gre0 up" it will then have the RUNNING flag and function as expected.

So far I have not been able to reproduce this in a VM, but it seems to only affect 2.1 and was not a problem on 2.0.

In the observed problem case, the GRE interface was configured, assigned with an IP set, gateway configured, and the GRE gateway was set as the default gateway. There was a static route set to reach the far-side GRE endpoint via a different local gateway. pf was disabled.

Workaround: Adding a shellcmd to "ifconfig gre0 up" at boot time allows it to function.

Associated revisions

Revision 11ad160e (diff)
Added by Ermal Luçi about 7 years ago

Normally when an ip is set the interface comes up on BSD stacks. Though push this commit which Fixes #3281

Revision 2b2d0d54 (diff)
Added by Ermal Luçi about 7 years ago

Normally when an ip is set the interface comes up on BSD stacks. Though push this commit which Fixes #3281

Revision 3945116d (diff)
Added by Chris Buechler about 7 years ago

bring up appropriate interface for GRE/GIF. Ticket #3281

Revision da2ec336 (diff)
Added by Chris Buechler about 7 years ago

bring up appropriate interface for GRE/GIF. Ticket #3281

Revision 7de6a47f (diff)
Added by Ermal Luçi over 6 years ago

Fixes #3281 do not undo any changes already done for gif/gre interface.

Revision 31cf5a93 (diff)
Added by Ermal Luçi over 6 years ago

Fixes #3281 do not undo any changes already done for gif/gre interface.

History

#1 Updated by Ermal Luçi about 7 years ago

  • Status changed from New to Feedback

#2 Updated by Ermal Luçi about 7 years ago

  • % Done changed from 0 to 100

#3 Updated by Ermal Luçi about 7 years ago

#4 Updated by Chris Buechler about 7 years ago

  • Status changed from Feedback to Resolved

I can't replicate, but the fix Ermal committed, and my later commit fixing the copy/paste-induced bug, should fix this since an ifconfig up works around it.

#5 Updated by Chris Buechler about 7 years ago

  • Status changed from Resolved to New
  • Target version changed from 2.1.1 to 2.2

Have a config from a customer that can replicate on all 2.1x versions. In projects git repo, redmine-3281.xml. That's a slightly modified customer config, changing the tunnel endpoint IPs to private IPs so it's not possible to bring up that config and potentially mess with their production setup. It has 5 GRE tunnels in that config, none of which get the RUNNING flag at boot time.

Root cause of this seems to be:
http://www.freebsd.org/cgi/query-pr.cgi?pr=138407

#6 Updated by Jim Thompson almost 7 years ago

  • Assignee set to Ermal Luçi

#7 Updated by Renato Botelho almost 7 years ago

  • Status changed from New to Feedback

I tried redmine-3281.xml on a 2.2 system and all GRE interfaces have RUNNING flag set on reboot.

#8 Updated by Chris Buechler over 6 years ago

  • Status changed from Feedback to Resolved

Every scenario I'm aware of where that wasn't working now is on 2.2.

#9 Updated by James Field over 6 years ago

I have 2.2-RC (amd64) built on Fri Jan 09 09:55:04 CST 2015 FreeBSD 10.1-RELEASE-p3 installed on Hyper-v 2012 R2
I am currently experiencing this issue, after a reboot the GRE tunnel is "up" but not "running". I need to type ifconfig gre0 up at the shell to get the tunnel working.

Also available in: Atom PDF