Project

General

Profile

Bug #3482

Initial Setup disables WAN

Added by Stefan Schindler over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
02/23/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1
Affected Architecture:

Description

I created a Xen-VM with
2 cores
2 nics, e1000
8 GB Disc
1 GB Ram

installed pfsense 2.1, no errors.

I connected with an other VM to the WebInterface, did the initial setup.
Here it get's interesting:

During the setup, the WAN connection works. Wan get's DHCP from the network. It's fine.
As the last step arrives, pfsense displays the "please wait"-sign and the uplink goes down.

After this I had to go to "Status" -> "Interfaces" -> "WAN" -> "DHCP" Release & Renew.
What I didn't test is, if a reboot would do the same.

Regards

History

#1 Updated by Chris Buechler over 4 years ago

  • Category changed from Web Interface to Interfaces
  • Target version set to 2.2

I've seen this on 2.1x, doesn't seem hardware-specific. haven't looked closely into it.

#2 Updated by Jim Thompson about 4 years ago

  • Assignee set to Chris Buechler

I can't assign this until we know how to duplicate it.

#3 Updated by Jim Pingle about 4 years ago

It's fairly easy to reproduce on a fresh install in VMware workstation.

1. Connect a client to the WAN network (or use the workstation)
2. Run pfSsh.php playback enableallowallwan (so you can reach the GUI from the WAN side)
3. Login to the firewall from the WAN side
4. Run through the wizard, leaving the WAN on DHCP
5. When the wizard is finished, the page never reloads, and if you check the console the WAN IP address is blank.

A reboot or release/renew of the WAN IP brings it back.

#4 Updated by Renato Botelho about 4 years ago

I couldn't reproduce it on similar setup using virtualbox. Let me know if I can have access to this box.

#5 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Resolved

This looks to be fixed already in 2.2.

The scenario where it's replicable in 2.1x is easy to duplicate. This is the scenario where I run into it all the time, but doesn't seem to be exclusive to this.

Boot up a completely default config, assign the interfaces, do a 'playback enableallowallwan' from the dev shell. Access the system via the WAN IP.

Go through the setup wizard, accept all the defaults without changing anything. When you click Reload at the end, you'll see you lose the DHCP-assigned IP on WAN. Short of killing dhclient and restarting it manually, or rebooting, it seems to stick there indefinitely with no IP assigned.

But do that on 2.2 as of today's snapshot and everything's fine. Been through a couple of scenarios that I know were an issue in 2.1x and neither is an issue on 2.2, so should be safe to say this is resolved.

Also available in: Atom PDF