Project

General

Profile

Actions

Bug #3770

closed

Some drivers not being built with altq support

Added by Jeff Rapp over 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Ermal Luçi
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
07/23/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2
Affected Architecture:

Description

The Intel igb driver is currently not being built with altq support enabled. This leads to a situation where the user is unable to properly add traffic shaping, and results in the following filter error message:

Jul 22 16:43:56 ne php-fpm[4044]: /rc.filter_configure_sync: New alert found: There were error(s) loading the rules: pfctl: igb0: driver does not support altq - The line in question reads [0]:

Actions #1

Updated by Jim Thompson over 7 years ago

  • Assignee set to Ermal Luçi
Actions #2

Updated by Ermal Luçi over 7 years ago

  • Subject changed from Intel igb driver not being built with altq support to Some drivers not being built with altq support
  • Status changed from New to Feedback

Patch has been committed that fixes the following cards:
- em
- igb
- ixgbe
- ixv
- oce
- sfxge
- virtio/vtnet
- vmxnet

Actions #3

Updated by Chris Buechler over 7 years ago

  • Status changed from Feedback to Resolved

fixed on everything I have handy to try

Actions #4

Updated by Michael Sh. over 7 years ago

But "bridge"?

Actions #5

Updated by Sam Bingner about 7 years ago

I'm not seeing ALTQ detected on vmxnet3 interfaces, and vmxnet2 is not detected at all... but this says that vmxnet has been fixed, which type of vmxnet interface needs to be selected, or has that fix been lost?

Actions #6

Updated by Chris Buechler about 7 years ago

it's there, was just overlooked in not being added to the list. I just fixed that.

Actions #7

Updated by Alexander Jakob almost 7 years ago

Hi i just changed to 2.2 and getting the same for run driver.

"There were error(s) loading the rules: pfctl: run0_wlan0: driver does not support altq - The line in question reads [0]"

when i look in /etc/inc/interfaces.ing run driver is listet there with altq support.

Mfg Alex

Actions #8

Updated by Chris Buechler almost 7 years ago

the issue with wireless is #4406

Actions

Also available in: Atom PDF