Project

General

Profile

Bug #4021

Bug #4062: pfSense_getall_interface_addresses truncates v6 link local IPs

Unbound doesn't handle v6 link local correctly

Added by Chris Buechler about 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
DNS Resolver
Target version:
Start date:
11/17/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

When choosing one of the "$interface IPv6 Link-local" options, it omits those from the unbound config.

Associated revisions

Revision a0e9e17d (diff)
Added by Chris Buechler about 5 years ago

If get_interface_ip(v6) is passed an IP, return the IP.

Properly set up interface binding for v6 link local IPs. Ticket #4021

except had to comment out the fix for now because of #4062 to avoid config breakage.

Revision 6cffaccc (diff)
Added by Chris Buechler about 4 years ago

Now that the issue in 4062 is fixed, no need to omit link local here. Ticket #4021

Revision 7cc0a76b (diff)
Added by Luiz Souza about 4 years ago

It is not necessary to omit link-local for unbound. Ticket #4021

Revision 5eb59cee (diff)
Added by Luiz Souza about 4 years ago

Fix get_interface_ip() to not return an IPv4 for a link-local request.

Fix get_interface_ipv6() to check for link-local prefix in original interface.

This fixes the generated unbound config, now it is possible to specify link-local addresses. Ticket #4021

Revision 525c9b73 (diff)
Added by Luiz Souza about 4 years ago

Pass the original interface and the correct address family to identify the real carp interface and retrieves its IP address. Ticket #4021

History

#1 Updated by Chris Buechler about 5 years ago

  • Status changed from New to Confirmed
  • Assignee set to Chris Buechler
  • % Done changed from 0 to 90
  • Parent task set to #4062

this is fixed, except I had to comment out the fix for now because of #4062

#2 Updated by Chris Buechler almost 5 years ago

  • Target version changed from 2.2 to 2.2.1

worked around this issue for the time being.

#3 Updated by Chris Buechler almost 5 years ago

  • Target version changed from 2.2.1 to 2.2.2

#4 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#5 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.3 to 2.3

#6 Updated by Chris Buechler about 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 90 to 100
  • Affected Version changed from 2.2 to 2.2.x

workaround removed now that #4062 is fixed. This is completely broken because of changes related to #4858. Leaving this to feedback until that's addressed, then this can be verified.

#7 Updated by Luiz Souza about 4 years ago

I committed a few fixes and it seems to be working now.

#8 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF