Project

General

Profile

Bug #4062

pfSense_getall_interface_addresses truncates v6 link local IPs

Added by Chris Buechler about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
11/17/2014
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Affected Version:
All
Affected Architecture:

Description

pfSense_getall_interface_addresses returns v6 link local IPs minus the %interface off the end. That makes get_possible_listen_ips() return an incomplete address that fails to bind. That leaves Unbound (at a minimum) broken, as it needs the full IP to function.

For instance, an interface with fe80::250:56ff:fea7:bba2%vmx0 will have fe80::250:56ff:fea7:bba2 returned as its link local. Unbound fails to bind unless it's listed as "interface: fe80::250:56ff:fea7:bba2%vmx0". I suspect other services will have the same issue.


Subtasks

Bug #4021: Unbound doesn't handle v6 link local correctlyResolvedChris Buechler

Associated revisions

Revision 352f8085 (diff)
Added by Chris Buechler about 4 years ago

Don't allow configuring IPv6 link local addresses on an interface. Ticket #4062

History

#1 Updated by Chris Buechler about 5 years ago

  • Assignee set to Ermal Luçi

#2 Updated by Ermal Luçi almost 5 years ago

I would push this on 2.2.1 since i am not yet able to evaluate if this is fixed what all is impacted.

#3 Updated by Chris Buechler almost 5 years ago

  • Target version changed from 2.2 to 2.2.1

only thing I'm aware of that was broken by this was unbound, and that was worked around within unbound, so yeah pushing to 2.2.1.

#4 Updated by Chris Buechler almost 5 years ago

  • Target version changed from 2.2.1 to 2.2.2

#5 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#6 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.3 to 2.3

#7 Updated by Paul K over 4 years ago

This also broke functionality in diag_ping and diag_testport pages.

#8 Updated by Jim Thompson over 4 years ago

  • Assignee changed from Ermal Luçi to Luiz Souza

reassign to Luiz

#9 Updated by Jim Thompson about 4 years ago

  • Assignee changed from Luiz Souza to Renato Botelho

reassigned, please also re-check https://redmine.pfsense.org/issues/5464

#10 Updated by Luiz Souza about 4 years ago

Committed a fix to PHP pfSense module: [[https://github.com/pfsense/FreeBSD-ports/commit/8c1058a09d955310164b2fd0900c95bed41065d9]]

Waiting for new snapshots to test and remove the old workarounds.

#11 Updated by Chris Buechler about 4 years ago

  • Status changed from Confirmed to Resolved

this is fixed. Workaround for #4021 because of this issue removed.

Also available in: Atom PDF