Project

General

Profile

Actions

Bug #4135

closed

package update code does not run new update code from +packagename+.inc file when upgrading a package.

Added by Pi Ba almost 7 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
-
Start date:
12/22/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1.5
Affected Architecture:
All

Description

package update code does not run new update code from packagename.inc file when upgrading a package.

For example:
When i had haproxy-devel pkg0.12 installed and pressed the 'reinstall haproxy-devel package' button, the new upgrade code from haproxy_custom_php_install_command() was not run first time.. After pressing the reinstall button a second time it did run the 0.13 update code. So thats an easy 'workaround', but shouldn't be needed right?.

I believe this is due to 'uninstalling' the package first loads the haproxy.inc file, then when new files are downloaded and haproxy.inc is needed again for the installation function, it is loaded from php's memory.

It could be that i did something wrong in the haproxy update structure, but i believe more packages experience this issue. Or must the solution be found in moving the package update code to a separate .inc file that is only included in the installation code.?

Actions #1

Updated by Renato Botelho almost 7 years ago

  • Status changed from New to Rejected

Duplicate of #3358

Actions #2

Updated by Chris Buechler over 6 years ago

  • Target version deleted (2.2)
Actions

Also available in: Atom PDF