Bug #4298


Excessive errors from snmpd

Added by Holger Hampel over 9 years ago. Updated over 3 years ago.

Very Low
Target version:
Start date:
Due date:
% Done:


Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:


When accessing snmp from a montitoring system I get many, many errors (logged in the central syslog):

snmpd95772: could not encode error response

I tried to disable some mibs, but there is no change.

Same monitoring worked in 2.1.5

Actions #1

Updated by Holger Hampel over 9 years ago

In the monitoring system there is a strange entry for IP:

Address Interface Netmask vtnet0 (1)

There are no more entries in this list - in 2.1.5 the list is complete.

Actions #2

Updated by Frankie Majowich almost 9 years ago

We are also experiencing the same issue. When doing snmp walk's against the pfsense firewall we get timeout's at different points in the walk.

Then get this error message: snmpd47919: could not encode error response.

We are running 2.2.2.

Actions #3

Updated by Jim Pingle over 8 years ago

  • Status changed from New to Closed

This is a bug in the mibII module of bsnmpd on FreeBSD 10.x and is not specific to pfSense.

It happens even on a vanilla FreeBSD 10.2-STABLE system not running pfSense. It needs to be reported upstream to FreeBSD.

Actions #4

Updated by Jim Pingle over 8 years ago

  • Status changed from Closed to Needs Patch
  • Assignee set to Luiz Souza
  • Priority changed from Normal to Very Low

Luiz said he may give this a look since he has worked on bsnmpd in the past.

Actions #5

Updated by Chris Buechler over 8 years ago

  • Status changed from Needs Patch to Assigned
  • Affected Version changed from 2.2 to 2.2.x

needs patch is a closed status. I'll put this to assigned if Luiz wants to take a look, otherwise we could file a FreeBSD PR and close this referencing back to it.

Actions #6

Updated by Viktor Gurov over 3 years ago

seems to be fixed in

needs testing


Also available in: Atom PDF