Project

General

Profile

Bug #4378

editing one of multiple pppoe connections with dial on demand enabled changes port assignment

Added by Bipin Chandra almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Interfaces
Target version:
Start date:
02/05/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Where you have dial on demand enabled on PPPoE, and have multiple PPPoE connections, saving on interfaces.php after making a config change results in it shifting the port assignment to the next PPPoE entry's port value.

History

#1 Updated by Chris Buechler almost 5 years ago

  • Subject changed from editing pppoe connections from interface menu orphans ppp entry link to editing pppoe connections on VLAN from interface menu orphans ppp entry link
  • Category set to Interfaces
  • Status changed from New to Feedback
  • Target version changed from 2.2.1 to 2.2.2

I can't replicate as described. I thought it was something to do with VLANs, but it works fine there in the exact configuration described. Any changes made don't impact it, the PPPoE traffic still functions and goes out via the VLANs.

going to need more info. A full backup of a config that replicates would help (can email it to me, cmb at pfsense dot org), or if you have some specific steps to replicate that are more involved than described.

#2 Updated by Bipin Chandra almost 5 years ago

mail sent with screenshot, config and way to replicate this

#3 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#4 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.3 to 2.3

#5 Updated by Phillip Davis over 4 years ago

@Bipin - I just fixed a different issue https://redmine.pfsense.org/issues/4568 where some things the interfaces.php page was doing were losing some data in the PPPs tab. But none of what I fixed seems related to what you are reporting.
Since I have just been looking at both interfaces.php and interfaces_ppps_edit.php I can probably spot the problem if you can tell me how to reproduce it. Post here or message me phil.davis on the forum.

#6 Updated by Bipin Chandra over 4 years ago

actually few months back when i opened this ticket, i had sent the config file and Chris and way to replicate, cant seem to find the email.
AFAIK i have a full install box running all wans on vlans and when i want to edit a certain wan, i do it from interfaces, mostly mtu, username and password, when i do that, the entry on ppp tab starts showing cua0....
the pppoe entry looses the interface so i have to edit that and reassign it.

could u ask Chris if he has those old emails as i sent him a config soon after that interface settings r lost from pppoe connection?

#7 Updated by Bipin Chandra over 4 years ago

i managed to trigger it again on the same box and got the config file, can u give me ur mail id so i can send the config file there.

steps
- this machine has 2 VLANs for LAN (LAN1 and LAN2)
- it has 3 WANs, 2 of them r pppoe and all on VLANs
- the VLAN 50 is for this WAN called BSNL, it was configured but under interfaces set to disabled
- on PPP tab it was showing the pppoe entry with VLAN 50 as interface
- all i did is went to interface->BSNL and enabled it and the interface broke from the pppoe entry
- i took the config backup with it broken so u could know whats missing

#8 Updated by Chris Buechler about 4 years ago

please send to cmb at pfsense dot org.

#9 Updated by Bipin Chandra about 4 years ago

i already did the last time

#10 Updated by Chris Buechler about 4 years ago

  • Subject changed from editing pppoe connections on VLAN from interface menu orphans ppp entry link to editing one of multiple pppoe connections with dial on demand enabled changes port assignment
  • Description updated (diff)
  • Status changed from Feedback to Resolved
  • Affected Version changed from 2.2 to All

Thanks Bipin, forgot you'd sent that already. I was able to replicate using that config.

Subject and original description updated to specific problem. If you have pppoe0 on vmx1 and pppoe1 on vmx2, with dial on demand enabled for both, and save a config change on pppoe0, its port ends up being switched to vmx2 on 2.2.x and older.

It's already fixed in 2.3.

#11 Updated by Bipin Chandra about 4 years ago

ok thanks, ill test it out when 2.3 snaps start coming out

Also available in: Atom PDF