Project

General

Profile

Bug #4513

Change in IP Alias name causes no tables on reboot

Added by B. Derman almost 5 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Unknown
Target version:
-
Start date:
03/11/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
amd64

Description

I've supplied 2 sanitized config files that were created as follows:

- restore working config (via Backup/restore page)
- reboot the router
- verify that tables were created
- download config (via Backup/restore page) ... this is the file "OK-config"
- change the IP Alias name from BEDiMacLAN1 to BEDiMacOnLAN1 (save and apply)
- note that no BEDiMacOnLAN1 table exists ... in my experience, this means "you're in trouble if you reboot"
- reboot the router
- verify that tables were NOT created
- download config (via Backup/restore page) ... this is the file "failing-config"

The failure occurs whether the various URL alias files are of zero size or are populated.

Both the production system and test systems this has been verified on are Core 2 Duo systems with 4 GB of memory. For me, this issue is 100% reproducible.

OK-config.xml (350 KB) OK-config.xml B. Derman, 03/11/2015 09:21 PM
failing-config.xml (350 KB) failing-config.xml B. Derman, 03/11/2015 09:21 PM

History

#1 Updated by B. Derman almost 5 years ago

This issue is still present in pfSense v2.2.1.

#2 Updated by Phillip Davis over 4 years ago

The problem is at line 929 in the configs above. The alias did not get renamed in the outbound rule. That has been fixed in commits
https://github.com/pfsense/pfsense/commit/682b8f12ab65bbb7821866a213bb6bd2d78c6507 (master)
https://github.com/pfsense/pfsense/commit/34f3165b543decc44456f510e97e056072a77009 (RELENG_2_2)
and was released in pfSense 2.2.3
This should be fixed now and turns out to be duplicate of #4701.

#3 Updated by Phillip Davis over 4 years ago

Bump this to make it appear later than the 200 entries Chris just mass-changed. I think this one can be closed as duplicate and resolved in 2.2.3

#4 Updated by B. Derman about 4 years ago

FWIW, I have verified that this is no longer an issue (i.e., it's fixed) in pfSense 2.2.6.

#5 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Duplicate
  • Affected Version deleted (2.2)

duplicate of #4701, thanks Phil and B. Derman.

Also available in: Atom PDF