Project

General

Profile

Bug #4701

WebGUI alias name changes does not reflect in NAT-Outbound

Added by Willy Tenner over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Rules / NAT
Target version:
Start date:
05/13/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

Just found two little bugs in the WEBgui:

Changing the name of an existing alias in "Firewall: Alias" will also change the references to it in all firewall rules. This is expected behaviour. The change will also be done in "Firewall: NAT: Port Forward" and "Firewall: NAT: 1:1". Regardless of whether the rules are enabled oder disabled.

Bug ##1:
But alias name changes does not reflect in "Firewall: NAT: Outbound". This seems to be a bug !

Bug ##2:
Another minor issue is in "Firewall: NAT: 1:1". Used aliases are not shown as aliases (not underlined) and moving the mouse over it does not show the little window with the resolved alias.

Associated revisions

Revision 682b8f12 (diff)
Added by Phillip Davis over 4 years ago

Fix alias rename and delete bug #4701

The old advancedoutbound key in config.xml is now called outbound.

Revision 34f3165b (diff)
Added by Phillip Davis over 4 years ago

Fix alias rename and delete bug #4701

The old advancedoutbound key in config.xml is now called outbound.

History

#1 Updated by Phillip Davis over 4 years ago

This fixes number 1:
https://github.com/pfsense/pfsense/pull/1654
The key in the config changed from "advancedoutbound" to "outbound" but the references to it for renaming and deleting aliases were not changed.

#2 Updated by Chris Buechler over 4 years ago

  • Project changed from pfSense Packages to pfSense
  • Category set to Rules / NAT
  • Status changed from New to Feedback
  • Affected Version changed from 2.2.2 to 2.2

thanks Phil.

the second issue I thought had another ticket, but not seeing it at the moment.

#3 Updated by Renato Botelho over 4 years ago

Pull request has been merged

#4 Updated by Renato Botelho over 4 years ago

  • % Done changed from 0 to 50

#5 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 50 to 100

works. Thanks!

#6 Updated by Chris Buechler over 4 years ago

  • Affected Version changed from 2.2 to 2.2.x

Also available in: Atom PDF