Project

General

Profile

Bug #5027

system_gateways_edit.php needs Advanced clean up

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
08/26/2015
Due date:
% Done:

100%

Estimated time:
Spent time:

Description

Similar to what you did on firewall rules page for instance.

Associated revisions

Revision b18a5d89 (diff)
Added by Steve Beaver over 3 years ago

Fixed #5027
Added toggle action to advanced option section

Revision d3981524 (diff)
Added by Steve Beaver over 3 years ago

Fixed #5027
Checkbox replaced with button

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Added toggle action to advanced options section

#2 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#3 Updated by Phillip Davis over 3 years ago

The old code checked if any of the advanced fields were set to non-default values.
If all advanced fields are at their default values then the Advanced button is shown on page load,
otherwise all the fields are shown (so the user can immediately see that they have specified some non-default Advanced setting).
Code around here did it:
https://github.com/pfsense/pfsense/blob/RELENG_2_2/usr/local/www/system_gateways_edit.php#L750

This applies in most of the other places were and Advanced button hides a group of advanced fields.

Sorry, I don't have anything to quickly test this on right now.

Does that behavior still work?

#4 Updated by Chris Buechler over 3 years ago

What Phil noted is one of the things I was going to get to eventually. For now, more keeping it to things that are completely broken.

Phil: if you're up for helping test, right now probably your best bet is checking out the bootstrap branch, cd to its src dir, and 'scp -r * root@<IP>:/' to a clean 2.2.4 install. Only on a test VM. :)

At least some, if not all, screens no longer have that.

I opened a new ticket on this general issue since it's separate, #5045.

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver

should be an advanced button like on firewall_rules_edit.php rather than a checkbox

#6 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Checkbox converted to button

#8 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF