Project

General

Profile

Actions

Bug #5045

closed

advanced fields not expanded automatically where such options are configured

Added by Chris Buechler about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
08/28/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:

Description

quoting from Phil Davis in #5027:

The old code checked if any of the advanced fields were set to non-default values.
If all advanced fields are at their default values then the Advanced button is shown on page load,
otherwise all the fields are shown (so the user can immediately see that they have specified some non-default Advanced setting).
Code around here did it:
https://github.com/pfsense/pfsense/blob/RELENG_2_2/usr/local/www/system_gateways_edit.php#L750

This applies in most of the other places were and Advanced button hides a group of advanced fields.


Files

DHCP-NTP.png (47.2 KB) DHCP-NTP.png Phillip Davis, 11/20/2015 09:36 AM
Actions #1

Updated by Jim Thompson about 6 years ago

  • Assignee set to Steve Beaver
Actions #2

Updated by Steve Beaver almost 6 years ago

Not all of the pages that sport "Advanced" buttons require this behavior. Looking through the 2.2.x codebase it looks like these are the pages that do. They are now ready for testing.

  • src/usr/local/www/services_dhcp.php
  • src/usr/local/www/firewall_rules_edit.php
  • src/usr/local/www/services_unbound.php
  • src/usr/local/www/system_gateways_edit.php
Actions #3

Updated by Steve Beaver almost 6 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler
Actions #4

Updated by Steve Beaver almost 6 years ago

  • % Done changed from 0 to 100
Actions #5

Updated by Renato Botelho almost 6 years ago

  • Project changed from Bootstrap to pfSense
Actions #6

Updated by Phillip Davis almost 6 years ago

Field descriptions can get lost. For example:
1) DHCP Server, click the Advanced box for NTP Servers.
2) Enter some NTP server address - e.g. 10.49.208.250 in the attached screen shot.
3) Save
4) Go away and come back to the page

The NTP server boxes are correctly displayed. But the Advanced box is not displayed at all. That includes the text in the left column that says "NTP Servers". So it is no longer obvious to the user what the fields actually are - they are just some IP addresses.

What is the best UI design here?

We could:
a) make sure that every individual field has some good description in the left-hand column - then if the row with the Advanced button goes away the user is not lost; or
b) make the row with the Advanced button be shown at all times - including on first page rendering even when the advanced fields need to be already expanded; or
c) ???

Actions #7

Updated by Chris Buechler over 5 years ago

  • Category set to Web Interface
  • Status changed from Feedback to Resolved
  • Target version set to 2.3
  • Affected Version set to 2.3

I believe we covered all these where they did so on 2.2.x.

Actions

Also available in: Atom PDF