Project

General

Profile

Actions

Bug #5111

closed

/usr/bin/dc is missing

Added by Sacha B about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Very High
Category:
Operating System
Target version:
Start date:
09/07/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2.x
Affected Architecture:
All

Description

/usr/bin/bc is missing:

bc: cannot find dc: No such file or directory

This is required by several scripts.

Actions #1

Updated by Chris Buechler about 6 years ago

  • Status changed from New to Not a Bug
  • Affected Version deleted (2.2.4)

not required by anything we ship. you can copy it over yourself if you're adding custom code that needs it.

Actions #2

Updated by Kill Bill about 6 years ago

Well, it's unfortunately used in /usr/local/bin/ping_hosts.sh

Actions #3

Updated by Jim Thompson about 6 years ago

  • Category set to Operating System
  • Status changed from Not a Bug to Duplicate
  • Assignee set to Renato Botelho
  • Target version set to 2.2.5
  • Affected Architecture All added
  • Affected Architecture deleted ()

https://github.com/pfsense/pfsense/blob/master/src/usr/local/bin/ping_hosts.sh#L113 uses /usr/bin/bc and bc is a driver for bc.

See: https://github.com/pfsense/FreeBSD-src/blob/devel/usr.bin/bc/bc.y#L1192

So Jakub / Kill Bill / Doctor Notor is correct here, and this is a bug.

No idea why I can't take this out of "Duplicate or Not a bug" status. I've moved it to "Duplicate" (even though it isn't) because it is a bug.

Actions #4

Updated by Jim Thompson about 6 years ago

  • Affected Version set to 2.2.x

Git blame says it was Renato in Dec 2013

https://github.com/pfsense/pfsense/commit/67e861292a48f6d94f8136699f8b74f21429af32

Apparently nobody has noticed.

Just put both 'bc' and 'dc' on the build, and we'll be fine.

Actions #6

Updated by Sacha B about 6 years ago

thanks guys for being so reactive.

Actions #7

Updated by Sacha B about 6 years ago

Chris Buechler wrote:

not required by anything we ship. you can copy it over yourself if you're adding custom code that needs it.

this is a standard shell application !

Actions #8

Updated by Chris Buechler about 6 years ago

  • Status changed from Duplicate to Feedback

thanks Kill Bill, et. al., I missed that.

Actions #9

Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to Resolved

fixed, thanks

Actions

Also available in: Atom PDF