Project

General

Profile

Bug #5114

squid3 version 0.3.0 errors

Added by Dave B over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Squid
Target version:
-
Start date:
09/09/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.4
Affected Architecture:
amd64

Description

> /var/squid/logs/cache.log <
2015/09/09 03:39:54 kid1| assertion failed: store_swapout.cc:307: "mem->swapout.sio == self"
2015/09/09 03:39:57 kid1| Starting Squid Cache version 3.4.10 for amd64-portbld-freebsd10.1...
2015/09/09 03:39:57| pinger: Initialising ICMP pinger ...
2015/09/09 03:39:57| icmp_sock: (1) Operation not permitted
2015/09/09 03:39:57| pinger: Unable to start ICMP pinger.
2015/09/09 03:39:57| icmp_sock: (1) Operation not permitted
2015/09/09 03:39:57| pinger: Unable to start ICMPv6 pinger.
2015/09/09 03:39:57| FATAL: pinger: Unable to open any ICMP sockets.

Just updated to the new squid3 version and now I'm having those error, the old version was working #1

History

#1 Updated by Kill Bill over 3 years ago

This has nothing to do with new version. In Proxy - General Config, check "Disable ICMP"

#2 Updated by Dave B over 3 years ago

even with ICMP disabled it still show those errors, the prior version wasn't doing this

and also wasnt doing this: kid1| assertion failed: store_swapout.cc:307: "mem->swapout.sio == self"

#3 Updated by Kill Bill over 3 years ago

Yeah, OK. This is not a place to seek support, kindly move this to https://forum.pfsense.org/index.php?board=60.0

Meanwhile, the pinger issue is fixed here: https://github.com/pfsense/pfsense-packages/pull/1053

#4 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback

#5 Updated by Cino . over 3 years ago

The issue with pinger is still there. I did an uninstall, reboot, install, reboot. I notice after the last reboot, the permissions changed from 4755 to 1223, strange.
This issue has been there ever since squid was updated for pfSense 2.2.x., its not a new issue at all.

#6 Updated by Cino . over 3 years ago

I did some further testing and manually changing the permissions then restarting the service seem to work. pinger starts. reboot the box, the permissions change back to 1223 tho. Looks like it changes it changes it to 1223 when pfSense starts the packages. It's still 4755 prior to pfSense calling the packages to start in the startup routine

#7 Updated by Kill Bill over 3 years ago

Yeah, the wrong permissions have been there ever since. It's now fixed in the package. If something's changing your permissions to nonsense like 1223, it sure like hell ain't the package.

#8 Updated by Dave B over 3 years ago

same problem with 0.3.1

#9 Updated by Dave B over 3 years ago

even if i chmod 4755 /usr/pbi/bin/libexec/squid/pinger
2015/09/09 13:03:16| pinger: Initialising ICMP pinger ...
2015/09/09 13:03:16| icmp_sock: (1) Operation not permitted
2015/09/09 13:03:16| pinger: Unable to start ICMP pinger.
2015/09/09 13:03:16| icmp_sock: (1) Operation not permitted
2015/09/09 13:03:16| pinger: Unable to start ICMPv6 pinger.
2015/09/09 13:03:16| FATAL: pinger: Unable to open any ICMP sockets.

#10 Updated by Dave B over 3 years ago

ok got to chmod 4755 /usr/pbi/squid-amd64/local/libexec/squid/pinger
fixed
but the package update won't fix it by himself

#11 Updated by Kill Bill over 3 years ago

I don't think I care any more. What could be done in the package is done. If reinstall/upgrade fails to apply permissions, take it with the pfSense developers.

#12 Updated by Kill Bill over 3 years ago

(IOW, to add to the above - the apparent bug here with package reinstalls is that the inc file is cached and you need to reinstall things twice to get the updated code actually do something. Needs to be fixed somewhere in /usr/local/www/pkg*.php, not in the package. The only viable workaround here is moving the install stuff to a separate PHP file. Stupid.)

#13 Updated by Dave B over 3 years ago

could we relay this to the pfsense devs so they can fix it?

I reinstalled the package at least 4 times, the issue is still there, pinger always end up with bad permissions

#14 Updated by Kill Bill over 3 years ago

Dave B wrote:

could we relay this to the pfsense devs so they can fix it?
I reinstalled the package at least 4 times, the issue is still there, pinger always end up with bad permissions

I'd assume someone reads it here. Good luck.

#15 Updated by Pi Ba over 3 years ago

The only issue with pfSense package manager is that if you 'reinstall' it uses the same package.inc file during uninstalling and reinstalling. A 'uninstall' + 'install' would work around that..

As for the permission issue, ive send a new pull request for it.: https://github.com/pfsense/pfsense-packages/pull/1056 which should fix that part..

#16 Updated by Kill Bill over 3 years ago

Pi Ba wrote:

As for the permission issue, ive send a new pull request for it.: https://github.com/pfsense/pfsense-packages/pull/1056 which should fix that part..

Probably should be just 04755. I'd frankly rather use exec() and /bin/chmod because whoever impletemented this chmod clusterfuck in PHP must have been completely retarded.

#17 Updated by Cino . over 3 years ago

Kill Bill wrote:

Yeah, the wrong permissions have been there ever since. It's now fixed in the package. If something's changing your permissions to nonsense like 1223, it sure like hell ain't the package.

Guess it was the coding in the package after all. I can confirm that its fix with the changes Pi Ba made. Thank you both for looking into it.

#18 Updated by Kill Bill over 3 years ago

Another attempt to fix this properly: https://github.com/pfsense/pfsense-packages/pull/1058/ (needs Squid3 reinstall and the above changes to get the permissions as really intended).

#19 Updated by Kill Bill over 3 years ago

Merged, please test 0.3.2 and report back. Regarding the pinger permissions, you MUST either uninstall Squid3 first and then reinstall, or upgrade and then reinstall again. (Nothing that could be done in package to work around this misfeature.)

#20 Updated by Dave B over 3 years ago

0.3.2 work #1!

#21 Updated by Kill Bill over 3 years ago

Thanks for testing. ;)

#22 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF