Project

General

Profile

Feature #5186

dhcp lease counter on status_dhcp_leases.php

Added by jeroen van breedam over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP (IPv4)
Target version:
Start date:
09/22/2015
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default

Description

Me & my collegues thought it would be useful to know how many leases are in use (without having to copy it to an excel sheet, or run a script)

i'm not a coder. the code in the pull request, probably, is not up to standards.
i've tested it on 3 running systems, ranging from 2.2.1 --> 2.2.4. seems to work fine.
please advise ;)

https://github.com/pfsense/pfsense/pull/1930

thanks in advance.

Associated revisions

Revision a0669cfb (diff)
Added by Renato Botelho 3 months ago

wg: Do not check assigned interface (Ticket #5186)

When saving changes on wireguard, do not check address conflict on
interface assigned to that tunnel, otherwise, it will not allow user to
save any modification

Revision 07aa50fd (diff)
Added by Renato Botelho 3 months ago

Ticket #5186: Fix comment

Revision 580c7a4f (diff)
Added by Renato Botelho 3 months ago

Ticket #5186: Implement is_wg_enabled()

Revision 39a615f0 (diff)
Added by Renato Botelho 3 months ago

Ticket #5186: Re-create config files during boot

Revision 06dda92e (diff)
Added by Renato Botelho 3 months ago

wg: Deny toconfigure IP address on wg interfaces

Ticket #5186

Revision 55da9aef (diff)
Added by Jim Pingle 3 months ago

Change XML listtag entry for peer to wgpeer for issue #5186

Revision 5a33a16c (diff)
Added by Jim Pingle 3 months ago

Ticket #5186: Enable Wireguard firewall rules tab

History

#2 Updated by Chris Buechler over 5 years ago

  • Category set to DHCP (IPv4)
  • Target version set to 2.3

#3 Updated by jeroen van breedam over 5 years ago

update:

the pull above is for releng 2_2

this one is for master: https://github.com/pfsense/pfsense/pull/1932

#4 Updated by jeroen van breedam over 5 years ago

this can probably be closed, 1932 has been merged.

thanks all

#5 Updated by Chris Buechler over 5 years ago

  • Status changed from New to Feedback

will leave for testing confirmation.

Thanks Jeroen!

#6 Updated by jeroen van breedam over 5 years ago

created an additional pull after someone asked me to add an 'interface' column to the lease_counter table.
i stumbled upon the get_configured_interface_with_descr() function to translate the OPTx to a useful name. not sure if that is ok or not. (saw it being used in services_dhcp.php)

https://github.com/pfsense/pfsense/pull/1937

#7 Updated by Jim Thompson over 5 years ago

  • Assignee set to Chris Buechler

#8 Updated by Jim Pingle over 5 years ago

  • Status changed from Feedback to Resolved

This appears to be working as intended for me on 2.3. Lease count is accurate, interface/pool info looks good. Might be helpful to see output from a larger deployment but if there is a newly discovered problem with it, we can open a bug report rather than keeping this open.

Also available in: Atom PDF