Project

General

Profile

Bug #5350

2.3 IPsec logging - silent can't be configured, issues with defaults

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
10/27/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Need to apply fixes from #5340 to 2.3. Closed #5340 with target 2.2.5 for tracking purposes.

A complication here because of the config upgrade diff between RELENG_2_2 and master, need to insert the 120 and bump all subsequent revisions that are in master only. Otherwise should be fine to port over exactly.

Associated revisions

Revision c53e411f (diff)
Added by Matthew Smith over 3 years ago

Fix #5350. Correct issues with strongswan logging (setting changes did not persist across reboots, setting silent did not work).

History

#1 Updated by Jim Thompson over 3 years ago

  • Assignee set to Matthew Smith

#2 Updated by Jim Thompson over 3 years ago

The 'fixes' for #5340 are kinda ugly, this needs rework.

#3 Updated by Matthew Smith over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#4 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Assigned

Looks like this commit broke upgrade_config.inc:

Warning: array_keys() expects parameter 1 to be array, null given in /etc/inc/upgrade_config.inc on line 4038

#5 Updated by Matthew Smith over 3 years ago

  • Status changed from Assigned to Feedback

fixed upgrade_config errors in 4df73fa0e2e02f1f48872663a30d4004dc3ce537

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF