Project

General

Profile

Bug #5364

IPsec status pages show all time units as seconds

Added by Chris Buechler almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Very Low
Assignee:
Category:
IPsec
Target version:
Start date:
11/02/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.5
Affected Architecture:

Description

The vici plugin outputs all status times in seconds, where SMP status output hours for times > 1 hour, minutes for times > 1 minute and < 1 hour, and seconds for times < 1 minute. It works fine, so we'll target 2.3 for this, just isn't user-friendly.

Associated revisions

Revision 00ae4060 (diff)
Added by Matthew Smith almost 4 years ago

Add "(hh:mm:ss)" in fields where time values are displayed in seconds on diag_ipsec.php. Fixes #5364

History

#1 Updated by Jim Thompson almost 4 years ago

  • Priority changed from Normal to Very Low

I'm OK with 'seconds'.

#2 Updated by Jim Pingle almost 4 years ago

We do have a function for this: convert_seconds_to_hms($sec) source:src/etc/inc/pfsense-utils.inc#L1171 - shouldn't be too hard to plumb in where needed since the values are already being printed by PHP, no?

#3 Updated by Jim Thompson almost 4 years ago

  • Assignee set to Matthew Smith

as suggested in chat, "xxxxxx seconds (hh:mm:ss)" seems best.

assigned

#4 Updated by Matthew Smith almost 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#5 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

Looks good, thanks! Not a big deal but most people don't recognize tens of thousands of seconds at a glance, and it's easy to make human-readable.

Also available in: Atom PDF