Project

General

Profile

Bug #5383

CODELQ Traffic Shaper Causes Panic and Reboot During Speed Test

Added by Chad Wagner over 5 years ago. Updated over 4 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
Operating System
Target version:
-
Start date:
11/07/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
Release Notes:
Default

Description

I started receiving seemingly random kernel panics after upgrading to 150/150 internet service.

Crash reports were submitted from the following IP addresses:
74.100.136.161
XX.X54.147.132 (my current IP)

I had been running running the DSLReports speed test http://www.dslreports.com/speedtest to check for bufferbloat and then setup CODELQ on all of my interfaces with a bandwidth of 142 mbits/sec. This would improve my bufferbloat score. After this I started to experience random kernel panics. After fully testing my hardware and finding it to be stable I put the system back online and ran a speed test. During the upload portion of the test the machine rebooted. I submitted this report from XX.X54.147.132. I then removed all shapers and am no longer experiencing random reboots and crash reports.

I have the following packages installed:
Avahi Network Management 1.10.3
Cron Services 0.3.2
OpenVPN Client Export Utility Security 1.2.20
Sarg Network Report 0.6.7
squid3 Network 0.4.2
squidGuard Network Management 1.9

Squid is running transparently.

Thread I was posting to:
https://forum.pfsense.org/index.php?topic=101686.msg567655#msg567655

Let me know if you need any further information

codelq.txt (207 KB) codelq.txt Daniel Grinkevich, 02/26/2016 11:23 AM

History

#1 Updated by Chad Wagner over 5 years ago

Just a quick update. Since turning off the CODELQ Traffic Shaper my box has been up for over 32 days without an issue.

#2 Updated by Chris Buechler about 5 years ago

  • Category set to Operating System

#3 Updated by Daniel Grinkevich about 5 years ago

I upgraded to 150/150 as well, enabled CODELQ on all interfaces and experienced the same crashing. I've attached the crash log.

#4 Updated by Luiz Souza almost 5 years ago

  • Assignee set to Luiz Souza

#5 Updated by Chad Wagner over 4 years ago

I just experienced this apparently same crash on 2.4 while running the DSLReports Speedtest. The system crashed after a couple of seconds into the upload speed portion of the test. I was not using CODELQ or any shapper when this crash occurred in 2.4. Reverting to 2.3.2 with the same configuration does not crash while running the speed test.

My system is:
Supermicro A1SRI-2558F
8GB ECC Ram
120GB Intel 320 SSD
Frontier FiOS 150/150

Also available in: Atom PDF