Project

General

Profile

Bug #5463

Cannot mark notices as read.

Added by Steve Wheeler almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
11/17/2015
Due date:
% Done:

100%

Estimated time:

Description

Generate some notices such that they appear on the right hand side on the top bar in GUI, by generating SSH keys for example. If you click on Notices you see the "pop-up" Notices window but clicking on 'Mark notices read' does not mark them read and hence there's no way to remove the notice indication.

Associated revisions

History

#1 Updated by Phillip Davis almost 4 years ago

It is working OK for me. I go to Diagnostics->Command Prompt and execute some PHP like:

file_notice("xyz","stuff");

and a notice(s) come.

I can click "Mark all as read" and they go away.

I am running and up-to-date 2.3-ALPHA

#2 Updated by Steve Beaver almost 4 years ago

Unable to reproduce.

Which browser/OS did you observe the problem with?

#3 Updated by Steve Wheeler almost 4 years ago

Yes, looks like my failure to test with more than one browser!
Doesn't work in Firefox under Linux Mint. Cleared fine with Chromium though.
Possibly some setting I have there blocking the javascript. Testing....

#4 Updated by Steve Wheeler almost 4 years ago

Confirmed. Some setting in FF 42 on Mint is preventing this though I can't find it.
FF 40 on GhpostBSD seems to have no issues, default settings, as does FF 42 on Xubuntu.

#5 Updated by Jim Pingle almost 4 years ago

Also fails for me in FF 42 on Mint+Cinnamon, Windows 10, and OS X 10.11.1. The FF install on OS X has no add-ons or extensions and a fairly basic config.

Might be worth starting FF with a new/blank profile as a test.

#6 Updated by Jim Pingle almost 4 years ago

Still fails with a blank FF profile. Testing against a NanoBSD box, might be a difference there. Chromium works though.

#7 Updated by Steve Wheeler almost 4 years ago

Tested against 32bit Nano and 64bit VM. Same result.

#8 Updated by Phillip Davis almost 4 years ago

Firefox 38.4.0ESR on Windows 10 has the problem.
Google Chrome Version 46.0.2490.86 m works.

So whatever the issue is, it occurs in multiple Firefox versions. I am not aware of any special settings I have done to Firefox - it should be out-of-the-box.

#9 Updated by Steve Beaver almost 4 years ago

I do most testing with FireFox (currently 43.0b3) and cannot reproduce. I'll experiment with different system and see what I can find. It is a very simple and straight forward piece of code though :(

#10 Updated by Steve Beaver almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Steve Wheeler

I have just pushed a simplified version of the header. It does the same thing but using a different mechanism. Would you test please and let me know if you see an improvement?

#11 Updated by Steve Beaver almost 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Steve Wheeler to Steve Beaver

Ready to test

#12 Updated by Steve Beaver almost 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Steve Wheeler

#13 Updated by Steve Beaver almost 4 years ago

  • % Done changed from 0 to 100

#14 Updated by Phillip Davis almost 4 years ago

This still does not work for me in Firefox 38.4.0ESR.
I tried ctrl-F5 to (hopefully) reload any cached JS or...
It still refuses to clear the notices.
It would be good to get feedback from others in case it is something in my particular Firefox.

#15 Updated by Jim Pingle almost 4 years ago

Works for me now in FF where it did not work before. On a current snap + gitsync though.

#16 Updated by Steve Beaver almost 4 years ago

If this continues to be a problem, I'll add some debug to help you track it down. Let's see what feedback we get from others.

#17 Updated by Chris Buechler almost 4 years ago

Same with Firefox 41 and 42 on Windows, including in FF safe mode.

#18 Updated by Steve Wheeler almost 4 years ago

Still not working for me in FF42 on Mint. Updated to latest code and Gitsynced to Master.

#19 Updated by Steve Beaver almost 4 years ago

Added some debbuging. You should get an alert on clicking the Clear button, and another when thee notices have been cleared.

You should also be able to clear the notices by navigating to index.php?closenotice=all

Please let me know what you find.

#20 Updated by Phillip Davis almost 4 years ago

That works in Firefox 38.4.0 and Google Chrome. Both using the UI and "closenotice=all" is good.
I can take the "normal" alert popups out of the code and it is still fine. This is the code I used to do a final round of tests without the alert popups:
https://github.com/pfsense/pfsense/pull/2087

#21 Updated by Chris Buechler almost 4 years ago

  • Assignee changed from Steve Wheeler to Steve Beaver

Also worked for me afterwards. I merged Phil's pull request to double check without the debug, and it's fine.

Will leave to feedback for Steve Beaver to review. Steve, if you're happy with how it stands now, safe to set this to resolved.

#22 Updated by Steve Beaver almost 4 years ago

  • Assignee changed from Steve Beaver to Steve Wheeler

Steve Wheeler - Can you confirm please?

#23 Updated by Steve Wheeler almost 4 years ago

Confirmed. Working fine with this mornings update in FF42 in Mint.

#24 Updated by Steve Beaver almost 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF