Project

General

Profile

Bug #5475

Gateways Dashboard widget should dynamically update

Added by Doug Dimick almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
11/17/2015
Due date:
% Done:

100%

Estimated time:

Associated revisions

History

#1 Updated by Chris Buechler almost 4 years ago

  • Tracker changed from Bug to Feature
  • Category set to Dashboard

#2 Updated by Phillip Davis almost 4 years ago

The Gateways widget in 2.2.5 refreshes the RTT, Loss and Status every 10 seconds. Is that what the OP means by "dynamically update"?
If so, then this is not a feature request.
In 2.3-ALPHA the 10 second refresh does not happen, at least not for me when I tested just now.
I guess that this is actually a bug report against 2.3 and Bootstrap?

#3 Updated by Jim Pingle almost 4 years ago

  • Tracker changed from Feature to Bug
  • Project changed from pfSense to Bootstrap
  • Category deleted (Dashboard)
  • Status changed from New to Confirmed
  • Assignee set to Steve Beaver
  • Target version set to 2.3
  • Affected Version set to 2.3
  • Affected Architecture set to All

Yes, this is definitely a regression, the widget updated dynamically before.

#4 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Fixed.

I will make the timer configurable and do the same to the IPSec widget shortly.

#5 Updated by Steve Beaver almost 4 years ago

  • % Done changed from 0 to 100

#6 Updated by Jim Pingle almost 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Jim Pingle to Steve Beaver

Updates OK but now it doesn't display the monitor IP.

#7 Updated by Phillip Davis almost 4 years ago

Works for me - thanks.

#8 Updated by Phillip Davis almost 4 years ago

I should always look for regressions also! JimP is correct - monitor IP has gone AWOL, even on first display.

#9 Updated by Phillip Davis almost 4 years ago

https://github.com/pfsense/pfsense/pull/2086
$display_type var setting needs to be earlier.

#10 Updated by Phillip Davis almost 4 years ago

and I just added another commit to that PR 2086 to remove some duplicated code that had snuck into master somewhere a while ago in the integration process.

#11 Updated by Steve Beaver almost 4 years ago

  • Status changed from Assigned to Resolved

Also available in: Atom PDF