Project

General

Profile

Bug #5504

/etc/hosts and /etc/syslog.conf are being overwritten by the base pkg, breaking their symlinks

Added by Jim Pingle almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
11/20/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

/etc/hosts is being overwritten by the base pkg, which breaks hosts setup by DNS forwarder/resolver since it expects a symlink to /var/etc/hosts
Similar story for /etc/syslog.conf which should be a link to /var/etc/syslog.conf

If you reboot again post upgrade /etc/rc will fix them both and make them links again, but we should probably exclude them from the base package.

Associated revisions

Revision 8248f5e4 (diff)
Added by Renato Botelho almost 4 years ago

Do not overwrite /etc/hosts and /etc/syslog.conf during base update. Fixes #5504

History

#1 Updated by Renato Botelho almost 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#2 Updated by Jim Thompson almost 4 years ago

Even though this is in 'Feedback', we should probably figure out how to get rid of the symlinks from /etc/hosts -> /var/etc/hosts, /etc/syslog.conf -> /var/etc/syslog.conf, etc.

Consider this a 2.4 TODO.

#3 Updated by Jim Pingle over 3 years ago

I seem to recall the reason for hosts being a symlink is because it gets updated frequently by processes like the DHCP host registration, so it's fairly volatile and on NanoBSD it would be impractical to switch that often.

The syslog.conf file should be static enough to eliminate the symlink fairly easily though.

The original problem as described on this ticket is fixed, I haven't had any issues with it since the fix went in. Should we keep this open or close it and move that other task to a new TODO for 2.4?

#4 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved
  • Affected Architecture deleted (amd64)

this is fixed, opened todo #5538 for removal in 2.4.

Also available in: Atom PDF