Project

General

Profile

Bug #5509

lighttpd regression causing config sync failures in some circumstances

Added by Chris Buechler almost 4 years ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Category:
XMLRPC
Target version:
Start date:
11/21/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.5
Affected Architecture:

Description

The upgrade to lighttpd 1.4.37 broke config synchronization for a small number of edge cases (specifics currently unknown, can't replicate at this time). It's been confirmed that backing down to 2.2.4's lighttpd 1.4.35 fixes.
https://forum.pfsense.org/index.php?topic=102135.0

History

#1 Updated by Jim Thompson almost 4 years ago

  • Assignee set to Chris Buechler

What does it take to tear the crap known as lighttpd out, and replace it with nginx?

#2 Updated by Jim Thompson almost 4 years ago

  • Assignee changed from Chris Buechler to Renato Botelho

#3 Updated by Renato Botelho over 3 years ago

I suspect this issue can be related this lighttpd issue:

http://redmine.lighttpd.net/issues/2670

It was fixed in 1.4.38, that is already available on 2.3 snaps and will be on 2.2.6-devel soon

#4 Updated by Renato Botelho over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Looks like lighttpd 1.4.38 fixed the problem

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved
  • Target version changed from 2.3 to 2.2.6

fixed

#6 Updated by Jim Pingle 4 days ago

  • Category changed from 62 to XMLRPC

Also available in: Atom PDF