Project

General

Profile

Feature #5644

Captive Portal retain logins across reboot

Added by Mantas Mikulėnas almost 4 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
Captive Portal
Target version:
Start date:
12/15/2015
Due date:
% Done:

100%

Estimated time:

Description

As far as I afaik, the captive portal logins are stored on disk – however they still get cleaned out every time pfSense is rebooted (whether for upgrades or not), requiring ~1500 people to relogin... Happens with every 2.1.x or 2.2.x version as far as I can see.

Associated revisions

Revision b0a29e82 (diff)
Added by A FL 6 months ago

Add allowed bandwith settings to sqlite DB
Implement redmine #5644

Revision 1d8a8f66 (diff)
Added by A FL 6 months ago

bump config
Implement redmine #5644

Revision 445c97fc (diff)
Added by A FL 6 months ago

Create an option for saving connected users across reboot
Implement redmine #5644

Revision 7b80e743 (diff)
Added by A FL 6 months ago

Restore connected users on boot when associated setting is enabled
Implement redmine #5644

History

#1 Updated by Chris Buechler almost 4 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Captive Portal forgets all logins on reboot to Captive Portal retain logins across reboot

That's by design, though it'd probably be OK to not rm the database on boot. Needs review for a variety of potential edge case problems that might introduce.

#3 Updated by Renato Botelho 6 months ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#4 Updated by A FL 6 months ago

I can confirm it's working well.
This issue can be marked as resolved

#5 Updated by Jim Pingle 6 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF