Project

General

Profile

Actions

Bug #5667

closed

NAT Reflection isn't working anymore since week of Dec 14th

Added by Richie Crews almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
NAT Reflection
Target version:
Start date:
12/28/2015
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:

Description

I've had this configuration working and haven't changed anything but in a recent 2.3 update it isn't working and my NAT configurations haven't changed. Let me know if you need any files from the install and how to generate them. Thanks!


Subtasks 1 (0 open1 closed)

Todo #5707: Replace inetd by xinetdResolvedRenato Botelho12/28/2015

Actions
Actions #1

Updated by Steve Beaver almost 6 years ago

  • Assignee set to Renato Botelho
Actions #2

Updated by Jim Pingle almost 6 years ago

Appears to be related to /etc/services being switched back to the standard FreeBSD copy, it wants the ports defined there that are used by inetd:
https://forum.pfsense.org/index.php?topic=104236.msg582238#msg582238

Actions #3

Updated by Chris Buechler almost 6 years ago

  • Status changed from New to Confirmed

separate issue but same root cause, that also broke tftp-proxy.

Actions #4

Updated by Jim Thompson almost 6 years ago

We should find a different way to repair this than to add all that crap back into /etc/services.

Actions #5

Updated by Renato Botelho almost 6 years ago

  • Status changed from Confirmed to Feedback

inetd was replaced by xinetd, please try next round of snapshots

Actions #6

Updated by Richie Crews almost 6 years ago

Confirmed to be working with NAT Proxy mode in 2.3-ALPHA (amd64) built on Mon Dec 28 08:00:57 CST 2015.

Actions #7

Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to Resolved

NAT+proxy reflection is working fine with xinetd now.

Actions

Also available in: Atom PDF