Project

General

Profile

Bug #5752

Problem with loading firewall rules when using pfBlocker

Added by Ivor Kreso over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
01/10/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

Currently running latest the pfSense 2.3, version 2.3.b.20160109.1400 and having slow load times of firewall rules page (any tab). Even when I click Firewall > Rules it takes up to 5 seconds, sometimes even longer to load the rules.

In versions prior to 2.3.b.20160109.1400 the same issue happened when trying to open Aliases page, but since the latest update, the issue is no longer there, instead it only remained on firewall rules. So whatever you did to Aliases, fixed it!

This was not a issue on 2.2.x with same pfBlocker configuration.

History

#1 Updated by Jim Thompson over 3 years ago

  • Assignee set to Steve Beaver

#2 Updated by Jim Thompson over 3 years ago

  • Affected Architecture set to All

Duplicated by #5757

Given #5757, I don't think the problem is specific to pfBlocker.

#3 Updated by Greg M over 3 years ago

No it`s not.
I can confirm same on:
2.3-BETA (amd64) built on Sat Jan 09 00:47:27 CST 2016

All pages are fine for me except rules tab which takes like 6 seconds to load.

#4 Updated by Ivor Kreso over 3 years ago

I can confirm I'm not having any issues with accessing interface settings, only when trying to access rules page and its tabs.

#5 Updated by Steve Beaver over 3 years ago

  • Status changed from New to Assigned
  • Assignee deleted (Steve Beaver)

Referring this to the pfBlockerNG developer for a second opinion

#6 Updated by Jim Thompson over 3 years ago

  • Assignee set to Steve Beaver

#7 Updated by Steve Beaver over 3 years ago

pfBlockerNG developer is investigating

#8 Updated by Greg M over 3 years ago

Hi!
Any progress on this one?

#9 Updated by BBcan177 . over 3 years ago

@Greg M,

Do you use pfBlockerNG? I can't find an issue with the package code...

#10 Updated by Greg M over 3 years ago

Nope, I only use:
Squid, snort, openvpn client export and RRD summary.
I think this is stock issue not package related...

#11 Updated by Steve Beaver over 3 years ago

This matter is being tracked on the forum here: https://forum.pfsense.org/index.php?topic=105852.0

#12 Updated by Steve Beaver over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Discovreed a work-around for this issue to prevent Firefox taking all week to initialize the "sortable" method.

#13 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Much, much faster for me on the system that was sluggish before. Works like a dream now, thanks! Closing.

Also available in: Atom PDF