Project

General

Profile

Bug #5809

Typo in siproxd config file prevents correct loading of plugins

Added by Willy Tenner over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
siproxd
Target version:
-
Start date:
01/24/2016
Due date:
% Done:

100%

Estimated time:
0.10 h
Affected Version:
Affected Architecture:
All

Description

Problem:
Typo in siproxd config file prevents correct loading of plugins

Description:
Using siproxd package version 1.0.8 there is a little typo in /usr/pbi/siproxd-amd64/local/etc/siproxd.conf.

According to Thomas Ries (author of the siproxd project) the "plugin_dir" path MUST be terminated with a '/'.
See http://siproxd.sourceforge.net/index.php?op=odoc , Chapter 3.1. The configuration file 'siproxd.conf'.

If plugin_dir is not terminated with '/', siproxd can not find any plugin files and you see errors in Status->System Logs->General:

Jan 23 21:51:51     siproxd[74098]: plugins.c:88 ERROR:plugin plugin_stun.la not found - skipped
Jan 23 21:51:51     siproxd[74098]: plugins.c:88 ERROR:plugin plugin_logcall.la not found - skipped

Workaround:
For persistent correction the file /usr/local/pkg/siproxd.inc has to be edited:

Change the line

$plugindir = SIPROXD . '/lib/siproxd';

to
$plugindir = SIPROXD . '/lib/siproxd/';

Please apply this patch to the next package version of siproxd (1.0.9?). Thank you.

History

#1 Updated by Jim Pingle over 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Applied in changeset pfsense-packages:commit:109b57fe3a51d65908582f825a398690a03ebd92.

#2 Updated by Jim Thompson over 4 years ago

  • Target version set to 2.3

#3 Updated by Jim Thompson over 4 years ago

  • Assignee set to Jim Pingle

#4 Updated by Jim Pingle over 4 years ago

  • Status changed from Feedback to Resolved

Works

#5 Updated by Chris Buechler over 4 years ago

  • Project changed from pfSense to pfSense Packages
  • Category changed from Package System to siproxd
  • Target version deleted (2.3)
  • Affected Version deleted (2.2.x)

Also available in: Atom PDF