Project

General

Profile

Bug #5830

dpinger pings dropped by some things because of no data payload

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Gateway monitoring
Target version:
Start date:
01/30/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

The root issue in this thread:
https://forum.pfsense.org/index.php?topic=105644.0

has been shown to be something dropping echo requests with no data payload in his cable modem (likely) or ISP's network. dpinger pings disappear. 'ping -s 0' disappears, -s >= 1 works fine. The echo requests disappear somewhere after leaving his WAN NIC, and before getting to the Internet. That situation is a common Cisco cable modem, next hop router is Casa Systems (same as my TWC at home, which has no issues).

While there's nothing wrong per RFC with excluding a data payload, dpinger is probably the only ping tool that will be widely used that does so by default, so we may trip bugs in other devices in rare edge cases like that. This is likely far from the first that will see issues as 2.3 gets more widely deployed.

Denny offered to add an option to specify a payload size in an email exchange we have going re: the issue. Then we can add an advanced option to gateways to allow configuring it for those who need to.

Associated revisions

Revision 85a2b065 (diff)
Added by Renato Botelho over 3 years ago

Fix #5830

Add a new advanced option on gateways to allow user define data
payload. Default is 0

History

#1 Updated by Jim Thompson over 3 years ago

  • Assignee changed from Chris Buechler to Renato Botelho

I'm not sure why we're going out of our way to accommodate equipment (from Cisco!) that isn't compliant with the standards.

Assigned to Renato, in case Denny Page ever actually releases said code.

#2 Updated by Michael Kellogg over 3 years ago

I would up vote this
Mainly cause I have had to deal with non compliant ISPs that refuse to change
In this case another mechanism to monitor connection health would be better
My ISP blocked Icmp for 5-7 years to "keep us the users safe "

#3 Updated by Denny Page over 3 years ago

Option to set data size has been released. Dpinger version 1.5.

#4 Updated by Jim Thompson over 3 years ago

Thanks Denny.

#5 Updated by Renato Botelho over 3 years ago

  • Status changed from Confirmed to Assigned

New dpinger is in place, working on GUI

#6 Updated by Renato Botelho over 3 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#7 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works as intended, thanks Denny and Renato.

Also available in: Atom PDF