Project

General

Profile

Bug #5831

After updating, on reboot pfSense is trying to fetch files

Added by Ivor Kreso over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
01/30/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

After each update so far, I've noticed that pfSense is trying to fetch files. This happens right before it actually starts the update. Check screenshot. I can provide more info if necessary.

Thanks.

Screen Shot 2016-01-30 at 13.43.06.png (21.6 KB) Screen Shot 2016-01-30 at 13.43.06.png Ivor Kreso, 01/30/2016 06:41 AM
upgrade_log.txt (4.51 KB) upgrade_log.txt Ivor Kreso, 01/30/2016 06:45 AM

Associated revisions

Revision 93a8ddf7 (diff)
Added by Renato Botelho over 3 years ago

Fix #5831

After PKG_AUTOUPDATE=false was removed, operations done during boot,
2nd and 3rd stages of upgrade process, are trying to update repository
metadata. The problem is during this stage we don't have a network
available yet and all needed packages were previously downloaded.

Add -U parameter to all read/write pkg calls during at these stages to
prevent pkg(8) to try to update metadata

Revision b69a106a (diff)
Added by Renato Botelho over 3 years ago

Fix #5831 using a simpler approach, just setting REPO_AUTOUPDATE=false when it's booting

History

#1 Updated by Chris Buechler over 3 years ago

  • Category set to Upgrade
  • Target version set to 2.3
  • Affected Version set to 2.3

#2 Updated by Ivor Kreso over 3 years ago

Full upgrade log attached per cmb's suggestion.

#3 Updated by Greg M over 3 years ago

Yeah, it happens to me as well.

#4 Updated by Jim Thompson over 3 years ago

  • Assignee set to Renato Botelho

#5 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#7 Updated by Renato Botelho over 3 years ago

  • Status changed from Feedback to Resolved

Ivor reported it's OK now

Also available in: Atom PDF