Project

General

Profile

Bug #5972

DHCPv6 Server Advanced Settings not displayed on page load

Added by Phillip Davis over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
03/10/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Setup DHCPv6 Server, click on any of the Advanced boxes, the various subsets of advanced settings are displayed.
Enter an advanced setting (e.g. put an NTP server).
Save

Go back to the page again.

All the Advanced sections are in their minimized state - with the Advanced button waiting to be clicked.
The section(s) that actually have advanced settings set should be opened for the user on page load.

This all works in the DHCPv4 server. Similar smart code needs to be added to services_dhcpv6.php
I am happy to have a look at it...

History

#1 Updated by Chris Buechler over 3 years ago

  • Category changed from DHCP (IPv6) to Web Interface
  • Status changed from New to Confirmed

You're welcome to it, Phil. Same as the v4 page would be fine, you know how it should work. :)

#2 Updated by Renato Botelho over 3 years ago

We can probably close this one in favor of #5994

#3 Updated by Phillip Davis over 3 years ago

This one is a bit different, because it is the one page where there is no smart code to auto-open the relevant Advanced sections on initial page load.
In any case, I will supply code for both this and #5994 together.

#5 Updated by Renato Botelho over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Thanks Phil!

#6 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

I tested the LDAP field and a couple others, seems to work OK for me.

Also available in: Atom PDF