Project

General

Profile

Bug #6422

PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60

Added by Jose Duarte over 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
-
Start date:
05/31/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.1
Affected Architecture:
amd64

Description

HA Setup, fw2. Crash reporter multiple times, might be related with XMLRPC sync (which has been failing some times, writes a xmlrpc lock, php-fpm restart needed everytime)

amd64
10.3-RELEASE-p3
FreeBSD 10.3-RELEASE-p3 # 2 1988fec(RELENG_2_3_1): Wed May 25 14:14:46 CDT 2016 root@ce23-amd64-builder:/builder/pfsense-231/tmp/obj/builder/pfsense-231/tmp/FreeBSD-src/sys/pfSense

Crash report details:
PHP Errors:
[31-May-2016 12:10:32 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:32 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:41 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:41 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:46 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:46 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:51 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:51 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:54 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:54 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:59 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:10:59 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:04 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:04 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:13 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:13 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:18 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:18 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:24 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:24 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:28 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:28 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:35 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:35 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:40 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:11:40 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:17 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:17 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:30 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:30 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:40 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:40 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:44 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
[31-May-2016 12:17:44 Europe/Berlin] PHP Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60

Logs show:
May 31 12:17:44 php-fpm 56068 /xmlrpc.php: Gateways status could not be determined, considering all as up/active. (Group: VPN_GatewayGroup)
May 31 12:17:44 php-fpm 56068 /xmlrpc.php: Gateways status could not be determined, considering all as up/active. (Group: VPN_GatewayGroup)
May 31 12:17:44 php-cgi rc.banner: PHP ERROR: Type: 1, File: /etc/inc/rrd.inc, Line: 60, Message: Call to undefined function gettext()
May 31 12:17:44 xinetd 28512 Reconfigured: new=0 old=1 dropped=0 (services)
May 31 12:17:44 xinetd 28512 readjusting service 6969-udp
May 31 12:17:44 xinetd 28512 Swapping defaults
May 31 12:17:44 xinetd 28512 Starting reconfiguration
May 31 12:17:44 php-cgi rc.banner: PHP ERROR: Type: 1, File: /etc/inc/rrd.inc, Line: 60, Message: Call to undefined function gettext()

History

#1 Updated by Chris Buechler over 3 years ago

  • Category changed from 62 to Operating System
  • Status changed from New to Feedback

are you running in Hyper-V or Azure by chance? That's the only place I've seen that, which occurs because it ends up getting access denied when trying to write the extensions.ini file during boot.

#2 Updated by Jose Duarte over 3 years ago

Hey Chris, I am running two R330 Dell server, bare metal. Anyway, I reinstalled the setup and for now I'm not seeing the error. I will update this ticket if I see it again.
Thanks.

#3 Updated by Momcilo Medic over 3 years ago

Hey Chris,

We've faced this issue as well.
We upgraded to 2.3.1 and we're seeing this error in menu:

Fatal error: Call to undefined function gettext() in /etc/inc/rrd.inc on line 60
PHP ERROR: Type: 1, File: /etc/inc/rrd.inc, Line: 60, Message: Call to undefined function gettext()
 0) Logout (SSH only)                  9) pfTop
 1) Assign Interfaces                 10) Filter Logs
 2) Set interface(s) IP address       11) Restart webConfigurator
 3) Reset webConfigurator password    12) pfSense Developer Shell
 4) Reset to factory defaults         13) Update from console
 5) Reboot system                     14) Disable Secure Shell (sshd)
 6) Halt system                       15) Restore recent configuration
 7) Ping host                         16) Restart PHP-FPM
 8) Shell

Enter an option:

Hope it helps.

Kind regards,
Momo.

#4 Updated by Jeff Hanks over 3 years ago

I've also just come across this error.

Call to undefined function gettext() in /etc/inc/rrd.inc on line 60

System logs also show:

rc.banner: PHP ERROR: Type: 1, File: /etc/inc/rrd.inc, Line: 60, Message: Call to undefined function gettext()

Also installed on bare metal, but I am not using HA.

#5 Updated by Jeffrey Posluns about 3 years ago

I've been getting this consistently on two new installs that are both dual-WAN load balanced (Gateway Groups).

Most of the time when it happens, check_reload_status consumes 100% CPU (usually PID 309). Killing the process from console then Restart PHP_FPM and Restart webConfigurator will resolve it.

Both are bare metal installs, one using separate NICs, and the other VLANS with one NIC (on an Intel NUC).

If there's any detail I can provide to help figure this out, please let me know.

#6 Updated by Glenn Provoost over 2 years ago

Seems to be caused by a file permissions issue.

See https://redmine.pfsense.org/issues/6758

To fix this:

chmod 644 /usr/local/etc/php/extensions.ini

#7 Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Duplicate

Duplicate of #6758

Also available in: Atom PDF