Project

General

Profile

Bug #6915

unbound logging not working after reboot or "Reset log files"

Added by idris budak 9 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
DNS Resolver
Target version:
Start date:
11/11/2016
Due date:
% Done:

100%

Affected version:
2.3.2
Affected Architecture:

Description

After "reboot the machine" or "Status => System Logs => Settings" => "Reset log files" then unbound logs are not sending to "resolver.log" or rsyslog.

After restarting the unbound service then logs are okey.

In version: 2.3.2-RELEASE-p1 (amd64)

Associated revisions

Revision ef72cd5c
Added by Doktor Notor 7 months ago

Restart unbound after clearing logs (Bug #6915)

Revision 2f15609c
Added by Doktor Notor 7 months ago

Restart unbound after clearing logs (Bug #6915)
(cherry picked from commit ef72cd5c2d36ff300de8de5971c05e19d1c9443c)

Revision 4aefa6f2
Added by Doktor Notor 6 months ago

Restart unbound after clearing logs (Bug #6915)

Handle clearing the individual log as well.

History

#1 Updated by Jim Thompson 8 months ago

  • Assignee set to Renato Botelho

#2 Updated by Kill Bill 7 months ago

The "reset log files" issue should be fixed by https://github.com/pfsense/pfsense/pull/3284

As for unbound logging not working after reboot, that's definitely not something I could reproduce anywhere.

#3 Updated by Renato Botelho 7 months ago

  • Status changed from New to Feedback
  • Priority changed from High to Normal
  • Target version set to 2.4.0
  • % Done changed from 0 to 100

PR has been merged

#4 Updated by Jim Pingle 6 months ago

  • Status changed from Feedback to Assigned

It works from the Settings tab if you reset all log files, but it doesn't work if you clear the log specifically while looking at the resolver tab (Click the wrench, then click Clear Log).

#5 Updated by Kill Bill 6 months ago

Jim Pingle wrote:

It works from the Settings tab if you reset all log files, but it doesn't work if you clear the log specifically while looking at the resolver tab (Click the wrench, then click Clear Log).

https://github.com/pfsense/pfsense/pull/3383

#6 Updated by Jim Pingle 6 months ago

  • Status changed from Assigned to Feedback

PR merged, works fine. Will wait for it to be in snaps before one last test.

#7 Updated by Jim Pingle 6 months ago

  • Status changed from Feedback to Resolved

Works

#8 Updated by Jim Pingle 6 months ago

  • Target version changed from 2.4.0 to 2.3.3

#9 Updated by Phillip Davis 6 months ago

This one shows up under "pfSense packages". Maybe because the category is set to "Unbound".
Other "modern" unbound issues have category "DNS Resolver"
Might e useful to correct for auto-generating reports.

#10 Updated by Jim Pingle 6 months ago

  • Project changed from pfSense Packages to pfSense
  • Category changed from Unbound to DNS Resolver

Yep, that's better, thanks!

Also available in: Atom PDF