Project

General

Profile

Bug #6931

Status > Filter Reload page is confusingly worded

Added by Steve Wheeler 7 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
11/14/2016
Due date:
% Done:

100%

Affected version:
All
Affected Architecture:
All

Description

The way the Filter Reload page is displayed implies that the filter rules are loaded by simply visiting the page.

The initially shows:
"This page will automatically refresh every 3 seconds until the filter is done reloading."
then after 3 seconds shows:
"Done. The filter rules have been reloaded".

But the filter rules are not actually reloaded until the button is pressed.

Associated revisions

History

#1 Updated by Jim Thompson 6 months ago

  • Assignee set to Steve Beaver

#2 Updated by Steve Beaver 6 months ago

  • Status changed from New to Feedback
  • Assignee changed from Steve Beaver to Steve Wheeler

Page un-uglyfied as requested

#3 Updated by Steve Beaver 6 months ago

  • % Done changed from 0 to 100

#4 Updated by Kill Bill 6 months ago

Uhm, dunno guys, it appears to me like this made the thing basically no-op? Previously, it's been showing what's going on during the reload. Now, it shows absolutely nothing, until you - quite a bit later, get "Done. The filter rules have been reloaded." Also, when when you get there via clicking the link shown after changing firewall rules and clicking apply, it basically does not even do the above. It shows totally nothing, just the "Reload" button.

I'd definitely prefer the "confusing" state.

#5 Updated by Steve Beaver 6 months ago

Previously when visiting the page from the status menu the page would say that it was reloading the filter then after three seconds say that it was done. That was not true. It looked like it was reloading hte filter, but it was really only updating the display.

Now you no longer get that fake display. When you click the button it reloads the filter and once finished, displays the "done" banner. Isn't that an improvement?

The clicking the button in the apply process is broken. I'll fix that.

#6 Updated by Kill Bill 6 months ago

I'm very sure the thing has actually been displaying real activity during reload. Such as, loading the various package firewall hooks, etc. Not anything fake. So now, it shows nothing, no idea where did the output go. It also does not refresh after 3 seconds, e.g. on an APU2 it takes some 10 seconds where it appears there's nothing going on at all (will probably make users click the button over and over again), then all of a sudden it shows "Done. The filter rules have been reloaded."

#7 Updated by Steve Beaver 6 months ago

The system I was testing on was too fast to notice the intermediate messages. Thanks for pointing that out. Fix coming.

#8 Updated by Steve Beaver 6 months ago

The root cause of the issue was that the filter reload process over-wrote the status file with every message, so there was only ever one line to read. On a fast system, that was always "Done".

The system has been changed to retain all filter status messages in the file, and to display them all on the page. No status messages should be lost, no matter the speed of the system being tested.

#9 Updated by Kill Bill 6 months ago

Thanks for looking into it (it's not like the exact messages would be really critical, but it was an indication of a progress - or of things getting stuck somewhere and at which point...) I got somehow lost in the related commits, so I guess I'll wait for the next snapshot to test this.

#10 Updated by Kill Bill 6 months ago

Wow, this is much better than before, shows complete progress output now. 8-) Thanks.

#11 Updated by Renato Botelho 6 months ago

  • Status changed from Feedback to Resolved

#12 Updated by Jim Pingle 4 months ago

  • Target version changed from 2.4.0 to 2.3.3

Also available in: Atom PDF