Project

General

Profile

Actions

Bug #6940

closed

OpenVPN management socket not listening after bootup / cannot restart the service.

Added by Pi Ba almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Category:
OpenVPN
Target version:
-
Start date:
11/17/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4
Affected Architecture:
amd64

Description

OpenVPN management socket not listening after bootup

The dashboard shows the following: "Unable to contact daemon / Service not running?"

However in diagnostics/sockets it can be seen that the openvpn process is running and listening.
Also its not possible to 'restart' the service through status/services its shown as not running, but started a second process whichs fails to bind the listen port..

Killing the process manually allows for it to be started through the gui again.

Currently i can consistently reproduce this issue each boot.. with: 2.4.0-BETA (amd64) built on Thu Nov 17 06:12:50 CST 2016

Actions #1

Updated by Jim Thompson almost 5 years ago

  • Assignee set to Renato Botelho
Actions #3

Updated by Renato Botelho almost 5 years ago

Can you give us more details about your setup? I couldn't replicate it on a box with some tunnels configured

Actions #4

Updated by Pi Ba almost 5 years ago

My setup 'at work' running on ESXi has 5 openvpn instances running on a carp-ip. Its connected to several networks/vlans 10 in total.
And when rebooting the master or backup box usually 1 or several of the openvpn widgets dont show their status. Its not very predictable though..

My current testbox on virtualbox has a gatewaygroup with 2 openvpn servers which are listening on that gateway group.
Tier1 has 2 gateways of which 1 is up.
Tier2 has 1 down gateway.
Pretty much always the openvpn widget shows "Unable to contact daemon" after a new daily snapshot is installed..

Actions #5

Updated by Renato Botelho almost 5 years ago

Pi Ba wrote:

My setup 'at work' running on ESXi has 5 openvpn instances running on a carp-ip. Its connected to several networks/vlans 10 in total.
And when rebooting the master or backup box usually 1 or several of the openvpn widgets dont show their status. Its not very predictable though..

My current testbox on virtualbox has a gatewaygroup with 2 openvpn servers which are listening on that gateway group.
Tier1 has 2 gateways of which 1 is up.
Tier2 has 1 down gateway.
Pretty much always the openvpn widget shows "Unable to contact daemon" after a new daily snapshot is installed..

Can you send me a copy of your testbox config.xml?

Actions #6

Updated by Pi Ba almost 5 years ago

Send by mail.

Actions #7

Updated by Renato Botelho almost 5 years ago

  • Status changed from New to Duplicate

Duplicate of #6132

Actions #8

Updated by Jim Pingle almost 5 years ago

  • Target version deleted (2.4.0)
Actions

Also available in: Atom PDF