Project

General

Profile

Bug #7265

Service dpinger does not start after upgrade from 2.3.3 to 2.4.0-Beta

Added by Philipp Haefelfinger 9 months ago. Updated 9 months ago.

Status:
Not a Bug
Priority:
Normal
Category:
Gateway monitoring
Target version:
Start date:
02/15/2017
Due date:
% Done:

0%

Affected Version:
2.4
Affected Architecture:
amd64

Description

From the day I upgraded my system to version 2.4.x dpinger did not start anymore and in the list of gateway I only see "pending".

pfSense: 2.4.0.b.20170215.1320
additional packages: AutoConfigBackup Cron Nut openvpn-client-export zabbix-agent
CPU: Intel(R) Xeon(R) CPU E3-1231 v3
RAM: 16GB DDR3 ECC
Network Total 6 NICs Intel Pro 1000). No bonding and no WLAN.
WAN: igb on VLAN-10 1Gbps per DHCP

I do not see any errors in syslog and have no clue what may cause the problem.

If I can provide any information that may help you, just tell me an I'll gather the information.

History

#1 Updated by Jim Thompson 9 months ago

  • Status changed from New to Assigned
  • Assignee set to Renato Botelho

#2 Updated by Denny Page 9 months ago

Is there anything in the system log for dpinger?

#3 Updated by Philipp Haefelfinger 9 months ago

If I look at Status -> System logs -> gateways I only see the following message:

Time    Process    PID    Message
Jan 21 00:20:47    kernel        dpinger: 2.0 -> 2.0_1 [pfSense]

There is nothing more to see and no error message that would indicate a problem or where the problem might be.
Hope this helps

Greets

Philipp

#4 Updated by Denny Page 9 months ago

The log entry doesn't make any sense to me. Please go to Status / Services and restart the dpinger daemon. Then post any messages in both Status / System Logs / System / General and Status / System Logs / System / Gateways. Thanks.

#5 Updated by Philipp Haefelfinger 9 months ago

Sorry for my delay. I was not at home these days.

I tried restarting the service. If I try to restart the service I only get the message I posted earlier. No new logs, no messages, no errors, nothing.

There is one thing I'm thinking of. Do you have some special settings on the WAN-Interface for dpinger to work? Because I had to switch to a config file to provide option 60 for swisscom dhcp. So if there have to be any speacial settings in the WAN-configuration, this might be a starting point.

One more hint: I have IPv6 disabled because the setup does not work well with swisscoms 6rd setup.

#6 Updated by Philipp Haefelfinger 9 months ago

ok, I found the issue with my system and it seems to work again.
As in my previous post described, the issue had to do with the custom wan configuration file. It started in pfsense 2.2 where the send option field was broken and the option dhcp-class-identifier "100008,0001,,pfSende dhclient 2.4" was split by the comma into multiple sends. So I configured the dhclient with a custom config file. But I did not think about it during the upgrade. Now I disabled this custom file and added the send option to the interface on the configpage and everything seems to work properly.

I consider this issue as solved and ready to close :-)

Sorry for taking your time and thanks for your support.

Keep up the good work!
I really love pfsense :-D

#7 Updated by Renato Botelho 9 months ago

  • Status changed from Assigned to Not a Bug

Also available in: Atom PDF