Project

General

Profile

Actions

Bug #7347

closed

Config Sync - Breaks on null value

Added by Clinton Cory about 5 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
XMLRPC
Target version:
-
Start date:
03/04/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4
Affected Architecture:

Description

When setting up config sync on a new box. If a config section is selected, in this example Virtual IPs, but nothing is defined in that section then it will generate an error:
"execption calling xmlrpc method restore_config_section impossible to encode value from type nulll no analogous type"

grep -Ril "restore_config_section" /etc/inc/
/etc/inc/xmlrpc_client.inc
/etc/inc/pfsense-utils.inc

If the config sync for that section is unselected no error is generated. This has only been tested with Virtual IPs on 2.4.

There should be an exception handler to overlook sections that are no yet defined rather than generating an error when saving config sync.

Actions #1

Updated by Jim Thompson about 5 years ago

  • Assignee set to Anonymous
Actions #2

Updated by Jim Pingle over 2 years ago

  • Category changed from 62 to XMLRPC
Actions #3

Updated by Marcos Mendoza 2 months ago

  • Status changed from New to Closed

Tested on 22.01 and could not reproduce issue - likely already resolved; closing due to lack of feedback and age.

Actions

Also available in: Atom PDF