Project

General

Profile

Bug #7378

pfctl: ix0: driver does not support altq

Added by Omer Iqbal over 3 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
03/11/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:
All

Description

Motherboard: Supermicro X10SDV-4C-TLN2F
using the onboard NIC: 2 RJ45 10GBase-T ports
2.3.3-RELEASE-p1 (amd64)
FreeBSD 10.3-RELEASE-p17

I went through the wizard to setup traffic shaping and get the following error:
There were error(s) loading the rules: pfctl: ix0: driver does not support altq - The line in question reads [0]: @ 2017-03-11 10:16:04

It seems this is related to 10GBase ports. I don't need 10G at this time but don't have any other NICs so if a workaround is possible, that would be greatly helpful.

Associated revisions

Revision d0bb073b (diff)
Added by Jim Pingle almost 3 years ago

Remove ix from the ALTQ interface list. See ticket #7378

Revision fea6f84d (diff)
Added by Jim Pingle almost 3 years ago

Remove ix from the ALTQ interface list. See ticket #7378

(cherry picked from commit d0bb073b2023c0551e1812f96aa8c6e2d7baba79)

History

#1 Updated by Luiz Souza over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to Luiz Souza
  • % Done changed from 0 to 100

Fix committed to RELENG_2_4, RELENG_2_3 and RELENG_2_3_3: https://github.com/pfsense/FreeBSD-src/commit/f2504b01d55b5cd3c625058869c4b9df1cf4525e

#2 Updated by Jim Pingle almost 3 years ago

  • Status changed from Feedback to Resolved

#3 Updated by Jim Pingle almost 3 years ago

  • Category set to Traffic Shaper (ALTQ)
  • Target version set to 2.4.2-p1
  • Affected Version set to 2.4.x
  • Affected Architecture All added
  • Affected Architecture deleted ()

Ultimately this was reverted at the time due to instability in the driver with ALTQ enabled.

See: https://forum.pfsense.org/index.php?topic=128064.msg706975#msg706975

It is not possible to support ALTQ on ix interfaces at this time.

#4 Updated by Renato Botelho 4 months ago

  • Status changed from Resolved to Feedback
  • Target version changed from 2.4.2-p1 to 2.5.0

I've re-enabled it on 2.5.0 snapshots so we can get it tested again

#5 Updated by Luiz Souza 4 months ago

  • Status changed from Feedback to Resolved

Tested okay on SG-5100.

Also available in: Atom PDF