Project

General

Profile

Bug #7751

Duplicated traffic graphs

Added by Greg M about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Graphs
Target version:
Start date:
08/03/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:

Description

When using VLANs traffic graph shows doubled traffic for out.
See discussion:https://forum.pfsense.org/index.php?topic=134506.0

History

#1 Updated by Scott D about 2 years ago

It appears to be the same behavior as https://redmine.pfsense.org/issues/3314 that was previously fixed, although I don't know if the cause is the same this time.

#2 Updated by Greg M about 2 years ago

Hi!

New details posted here: https://forum.pfsense.org/index.php?topic=134506.0
Seems that it is pfSense bug since nload is showing correct data.

Thanks @PiBa for pointing me to the tool to test it.

#3 Updated by Jared Dillard about 2 years ago

  • Category set to Traffic Graphs
  • Assignee set to Jared Dillard

#4 Updated by Jared Dillard about 2 years ago

  • Status changed from New to Confirmed
  • Assignee changed from Jared Dillard to Luiz Souza

This has happened before in #3314 and was fixed in https://github.com/pfsense/pfsense-tools/commit/ad55e66a3fb817f8e54bae7bf38306039b82e3ad, then later ported in https://github.com/pfsense/FreeBSD-src/commit/939f11b196e7d22a1ce3da8533e97ff3e92510b6#diff-437f2b0c100f75faf75f7c5b60eca6a4R1156.

Then later in February 2017, the difference appears to be introduced in this commit: https://github.com/pfsense/FreeBSD-src/commit/5c1daa5ea1098b67d4c331d5e21b39178d616031

As PiBa points out on the mentioned forum thread, here is a difference in https://github.com/pfsense/FreeBSD-src/blob/RELENG_2_4/sys/net/if_vlan.c#L1132:

2.3:

             ifp->if_opackets++;
             //ifp->if_omcasts += mcast;
             //ifp->if_obytes += len;

2.4:

            if_inc_counter(ifp, IFCOUNTER_OPACKETS, 1);
            if_inc_counter(ifp, IFCOUNTER_OBYTES, len);
            if_inc_counter(ifp, IFCOUNTER_OMCASTS, mcast);

Luiz since you made that last commit could you take a look at this? Both you and garga have made edits to the file so not sure who is best.

#5 Updated by Luiz Souza about 2 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Yeah, the packets are being counted twice, I overlooked this change.

It will be fixed in tomorrow snapshot.

Thanks!

#6 Updated by Greg M about 2 years ago

Thanks guys!
Confirmed working OK on todays snap :)

#7 Updated by Luiz Souza about 2 years ago

  • Status changed from Feedback to Resolved

#8 Updated by Scott D about 2 years ago

I know this has already been closed but I can also confirm that it working properly now. Thanks Luiz/Jared!

Also available in: Atom PDF