Project

General

Profile

Bug #7807

sg-1000 random reboot when traffic shaping enabled

Added by Bipin Chandra almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper
Target version:
-
Start date:
08/23/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:

Description

Based on this discussion https://forum.pfsense.org/index.php?topic=135450.0

When u enable traffic shaping with those standard 5 queues and use floating rules to assign traffic to them, then in certain traffic conditions where u have around 20-30 mbps of data flowing to or from wan and at same time u open web gui and it just reboots abruptly, there is no crash log generated at all. I tried with and without ramdisk as well as watchdog timer but this reboot happens randomly.

After disabling traffic shaping the problem solves.

CropperCapture[1].jpg (329 KB) CropperCapture[1].jpg traffic shaping queues Bipin Chandra, 09/10/2017 02:33 AM
Capture[1].jpg (24.9 KB) Capture[1].jpg traffic shaping queues Bipin Chandra, 09/10/2017 02:34 AM
crash.txt (269 KB) crash.txt for apu2 Bipin Chandra, 09/25/2017 10:37 AM
crash2.txt (268 KB) crash2.txt for apu2 Bipin Chandra, 09/25/2017 10:37 AM

History

#1 Updated by Bipin Chandra almost 2 years ago

this also happens on the apu2 when u have 2 WAN connections and floating match rules to assign traffic to queues for each wan connection, i have another apu2 box with single wan and that doesnt crash and reboot

#2 Updated by Bipin Chandra almost 2 years ago

sorry attached the wrong image earlier, kindly delete that

#3 Updated by Bipin Chandra almost 2 years ago

i noticed it crashes and reboots when u max out any one internet line by running speedtest.net above 50mbps download speed, happen on single wan connections too

#4 Updated by Renato Botelho almost 2 years ago

  • Target version changed from 2.4.0 to 2.4.1

#5 Updated by Bipin Chandra almost 2 years ago

crash log attached

#6 Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Duplicate
  • Target version deleted (2.4.1)
  • Affected Architecture deleted (SG-1000)

Neither of those logs contain useful information, the most important parts are before those logs start. If you captured those on the console, set a larger buffer in your console client. The logs are not for SG-1000, either, which is what the ticket was opened for. If the crash is specific to SG-1000, it needs to only contain SG-1000 info. If it's a more general issue, then it needs a more general ticket. Looking at the thread, whatever is left is likely covered by #7879 already, closing this as a duplicate.

#7 Updated by Bipin Chandra almost 2 years ago

ok ill try to get crash log again, on apu2 it crashes as soon as u enable shaping on more than 1 interface and on sg-1000 it happens only after u hit 50mbps download

Also available in: Atom PDF