Project

General

Profile

Bug #7879

traffic shaper crashes with hfsc_dequeue

Added by Pi Ba almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Very High
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
09/19/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:
amd64

Description

Today i experienced several crashes in 2.4RC i think there were at least 5.
Ive submitted the crash report a few times i think 3, but it didn't always offer to do so after bootup..
The IP the dumps are submitted from likely starts with 85.146.

version:
Build: eed6fd412cc(RELENG_2_4_0): Fri Sep 15 16:11:43 CDT 2017

I've upgraded a 2.3.4_1 box that has been running fine for months if not years on this ESXi machine, all 5 nics are virtual 'E1000' nics of which one is used to provide several vlans from inside pfSense, HFSC traffic shapping configured on 4 pfSense interfaces of which 2 are vlans..
So i upgraded Friday evening, then Tuesday morning nothing strange happened, then today it crashed 5 times in 4 hours..

db:0:kdb.enter.default>  show pcpu
cpuid        = 1
dynamic pcpu = 0xfffffe00981f1200
curthread    = 0xfffff800034a9a00: pid 0 "em0 taskq" 
curpcb       = 0xfffffe002b4cfb80
fpcurthread  = none
idlethread   = 0xfffff800031d7a00: tid 100004 "idle: cpu1" 
curpmap      = 0xffffffff829e6300
tssp         = 0xffffffff82a1eb78
commontssp   = 0xffffffff82a1eb78
rsp0         = 0xfffffe002b4cfb80
gs32p        = 0xffffffff82a253d0
ldt          = 0xffffffff82a25410
tss          = 0xffffffff82a25400
db:0:kdb.enter.default>  bt
Tracing pid 0 tid 100031 td 0xfffff800034a9a00
kdb_enter() at kdb_enter+0x3b/frame 0xfffffe002b4cf270
vpanic() at vpanic+0x19f/frame 0xfffffe002b4cf2f0
panic() at panic+0x43/frame 0xfffffe002b4cf350
hfsc_dequeue() at hfsc_dequeue+0x633/frame 0xfffffe002b4cf390
tbr_dequeue() at tbr_dequeue+0xdf/frame 0xfffffe002b4cf3e0
vlan_start() at vlan_start+0x12c/frame 0xfffffe002b4cf440
if_transmit() at if_transmit+0x1a5/frame 0xfffffe002b4cf490
ether_output() at ether_output+0x728/frame 0xfffffe002b4cf520
ip_output() at ip_output+0x1746/frame 0xfffffe002b4cf670
ip_forward() at ip_forward+0x36b/frame 0xfffffe002b4cf710
ip_input() at ip_input+0x6ee/frame 0xfffffe002b4cf770
netisr_dispatch_src() at netisr_dispatch_src+0xa5/frame 0xfffffe002b4cf7d0
ether_demux() at ether_demux+0x15c/frame 0xfffffe002b4cf800
ether_nh_input() at ether_nh_input+0x317/frame 0xfffffe002b4cf860
netisr_dispatch_src() at netisr_dispatch_src+0xa5/frame 0xfffffe002b4cf8c0
ether_input() at ether_input+0x26/frame 0xfffffe002b4cf8e0
if_input() at if_input+0xa/frame 0xfffffe002b4cf8f0
lem_rxeof() at lem_rxeof+0x513/frame 0xfffffe002b4cf9a0
lem_handle_rxtx() at lem_handle_rxtx+0x32/frame 0xfffffe002b4cf9e0
taskqueue_run_locked() at taskqueue_run_locked+0x14a/frame 0xfffffe002b4cfa40
taskqueue_thread_loop() at taskqueue_thread_loop+0xe8/frame 0xfffffe002b4cfa70
fork_exit() at fork_exit+0x85/frame 0xfffffe002b4cfab0
fork_trampoline() at fork_trampoline+0xe/frame 0xfffffe002b4cfab0
--- trap 0, rip = 0, rsp = 0, rbp = 0 ---

I think i saw somewhere there was a request for how the queue's are configured, anyhow ive got these:


 altq on em0 hfsc qlimit 75  bandwidth 45Mb tbrsize 20480 queue {  WAN_DEF,  ftpq,  ftpaq,  voipQ,  voipAQ,  AZ-Backup-q,  AZ-backup-aq  } 
 queue WAN_DEF on em0 bandwidth 10Mb qlimit 500 hfsc (  default  , upperlimit 45Mb  )  
 queue ftpq on em0 bandwidth 5Mb qlimit 201 
 queue ftpaq on em0 bandwidth 2Mb 
 queue voipQ on em0 bandwidth 10Mb qlimit 100 hfsc (  realtime 10Mb )  
 queue voipAQ on em0 bandwidth 2Mb qlimit 100 hfsc (  realtime 2Mb )  
 queue AZ-Backup-q on em0 bandwidth 10Mb qlimit 250 hfsc (  ecn  , codel  , upperlimit 30Mb  )  
 queue AZ-backup-aq on em0 bandwidth 100Kb hfsc (  upperlimit 800Kb  )  

 altq on em1 hfsc bandwidth 1000Mb queue {  lan-test,  LAN_DEFq,  lan-test2,  AZ-Backup-q,  AZ-backup-aq  } 
 queue lan-test on em1 bandwidth 20Kb hfsc (  red  , upperlimit 80Kb  )  {  l-in,  l-uit  } 
 queue l-in on em1 bandwidth 50% 
 queue l-uit on em1 bandwidth 50% 

 queue LAN_DEFq on em1 bandwidth 800Mb hfsc (  codel  , default  )  
 queue lan-test2 on em1 bandwidth 20Kb hfsc (  red  , upperlimit 10Kb  )  
 queue AZ-Backup-q on em1 bandwidth 10Mb qlimit 80 hfsc (  upperlimit 40Mb  )  
 queue AZ-backup-aq on em1 bandwidth 500Kb qlimit 250 hfsc (  ecn  )  

 altq on em3 hfsc qlimit 75  bandwidth 50Mb tbrsize 20480 queue {  wan-def,  ftpq,  ftpaq,  voipQ,  voipAQ  } 
 queue wan-def on em3 bandwidth 10Mb qlimit 500 hfsc (  default  )  
 queue ftpq on em3 bandwidth 5Mb qlimit 201 
 queue ftpaq on em3 bandwidth 2Mb 
 queue voipQ on em3 bandwidth 10Mb qlimit 100 hfsc (  realtime 10Mb )  
 queue voipAQ on em3 bandwidth 2Mb qlimit 100 

 altq on em4_vlan12 hfsc bandwidth 1000Mb queue {  opt5def,  ftpq,  ftpaq  } 
 queue opt5def on em4_vlan12 bandwidth 800Mb hfsc (  default  )  
 queue ftpq on em4_vlan12 bandwidth 130Mb 
 queue ftpaq on em4_vlan12 bandwidth 1170Kb qlimit 200 

 altq on em4_vlan15 hfsc qlimit 200  bandwidth 1000Mb queue {  defaultq,  voipQ,  voipAQ  } 
 queue defaultq on em4_vlan15 bandwidth 900Mb hfsc (  default  )  
 queue voipQ on em4_vlan15 bandwidth 10Mb hfsc (  realtime 10Mb )  
 queue voipAQ on em4_vlan15 bandwidth 2Mb hfsc (  realtime 2Mb )  

em3 is a 'disabled' interface though..

History

#1 Updated by Jim Thompson almost 2 years ago

  • Assignee set to Luiz Souza

Possible duplicate of #7877

#2 Updated by Pi Ba almost 2 years ago

I tried 2.4.1 with 'em' E1000 nics on ESXi.. that crashes to..
Version 2.4.1-DEVELOPMENT (amd64)
built on Sat Sep 23 19:46:59 CDT 2017
FreeBSD 11.1-RELEASE-p1

(crashdump submitted.. not sure from what ip.. likely starts with either 185.21.. or 185.186.. )

#3 Updated by Luiz Souza almost 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Found and fixed, a new commit was made to address this issue.

Please test again on the next snapshot.

Thanks!

#4 Updated by Pi Ba almost 2 years ago

After initial testing with and pushing some traffic through my queue's which seemed like a sure way to crash it before, i'm gone try and see how it holds up tomorrow :) sofar looking good.

Thank YOU !

[code]2.4.0-RC (amd64)
built on Mon Sep 25 15:04:23 CDT 2017
FreeBSD 11.0-RELEASE-p12 [/code]

#5 Updated by Renato Botelho almost 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF