Project

General

Profile

Bug #7869

Hyper-v vm traffic shaper error: hn0: driver does not support altq

Added by Nadav Rak about 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
09/16/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:

Description

after applying traffic shaper in a clean and new installed 2.4RC on a Hyper-v vm I got this message:

There were error(s) loading the rules: pfctl: hn0: driver does not support altq - The line in question reads [0]:

when install a stable version (2.3.4_p1) on the same mechine with the same settings - all went well.
my server: HP ML150 Gen9, intel Xnon E5-2620, HPE Ethernet 1Gb 2-port 361T Adapter (IntelĀ® Ethernet I350 controller)
OS: hyper-v on nano server
vm: basic (gen1) hyper-v vm, 2 network adapters (not legacy), network adapters connected using a VLAN ID at the Hyper-v level (pfsense see's a regular untagged lan).

pfsense: new installed 2.4.0.r.20170905.1652 pfsense (zfs filesystem), no modifications or any change to default settings. after setting traffic shaper with wizard I've got this log:

Initializing
Creating aliases
Creating gateway group item...
Generating Limiter rules
Generating NAT rules
Creating 1:1 rules...
Creating outbound NAT rules
Creating automatic outbound rules
Setting up TFTP helper
Generating filter rules
Creating default rules
Pre-caching Default allow LAN to any rule...
Creating filter rule Default allow LAN to any rule ...
Creating filter rules Default allow LAN to any rule ...
Setting up pass/block rules
Setting up pass/block rules Default allow LAN to any rule
Creating rule Default allow LAN to any rule
Pre-caching m_P2P BitTorrent outbound...
Creating filter rule m_P2P BitTorrent outbound ...
Creating filter rules m_P2P BitTorrent outbound ...
Setting up pass/block rules
Setting up pass/block rules m_P2P BitTorrent outbound
Creating rule m_P2P BitTorrent outbound
Pre-caching m_P2P BitTorrent outbound...
Creating filter rule m_P2P BitTorrent outbound ...
Creating filter rules m_P2P BitTorrent outbound ...
Setting up pass/block rules
Setting up pass/block rules m_P2P BitTorrent outbound
Creating rule m_P2P BitTorrent outbound
Pre-caching m_Other MSRDP outbound...
Creating filter rule m_Other MSRDP outbound ...
Creating filter rules m_Other MSRDP outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other MSRDP outbound
Creating rule m_Other MSRDP outbound
Pre-caching m_Other VNC outbound...
Creating filter rule m_Other VNC outbound ...
Creating filter rules m_Other VNC outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other VNC outbound
Creating rule m_Other VNC outbound
Pre-caching m_Other PPTP outbound...
Creating filter rule m_Other PPTP outbound ...
Creating filter rules m_Other PPTP outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other PPTP outbound
Creating rule m_Other PPTP outbound
Pre-caching m_Other PPTPGRE outbound...
Creating filter rule m_Other PPTPGRE outbound ...
Creating filter rules m_Other PPTPGRE outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other PPTPGRE outbound
Creating rule m_Other PPTPGRE outbound
Pre-caching m_Other IPSEC outbound...
Creating filter rule m_Other IPSEC outbound ...
Creating filter rules m_Other IPSEC outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other IPSEC outbound
Creating rule m_Other IPSEC outbound
Pre-caching m_Other IPSEC outbound...
Creating filter rule m_Other IPSEC outbound ...
Creating filter rules m_Other IPSEC outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other IPSEC outbound
Creating rule m_Other IPSEC outbound
Pre-caching m_Other IPSEC outbound...
Creating filter rule m_Other IPSEC outbound ...
Creating filter rules m_Other IPSEC outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other IPSEC outbound
Creating rule m_Other IPSEC outbound
Pre-caching m_Other DNS1 outbound...
Creating filter rule m_Other DNS1 outbound ...
Creating filter rules m_Other DNS1 outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other DNS1 outbound
Creating rule m_Other DNS1 outbound
Pre-caching m_Other DNS2 outbound...
Creating filter rule m_Other DNS2 outbound ...
Creating filter rules m_Other DNS2 outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other DNS2 outbound
Creating rule m_Other DNS2 outbound
Pre-caching m_Other MySQL1 outbound...
Creating filter rule m_Other MySQL1 outbound ...
Creating filter rules m_Other MySQL1 outbound ...
Setting up pass/block rules
Setting up pass/block rules m_Other MySQL1 outbound
Creating rule m_Other MySQL1 outbound
Creating IPsec rules...
Creating uPNP rules...
Generating ALTQ queues
Loading filter rules
Setting up logging information
Setting up SCRUB information
There were error(s) loading the rules: pfctl: hn0: driver does not support altq - The line in question reads [0]: 

*so to see if the problem is in my computer, I've tested it on the same virtual machine with the same settings on 2.3.4_p1, and the error did not occur *

Generating ALTQ queues
Loading filter rules
Setting up logging information
Setting up SCRUB information
Processing down interface states
Running plugins
Running plugins (pf)
Plugins completed.
Done

History

#1 Updated by Jim Thompson about 2 years ago

  • Assignee set to Luiz Souza

#2 Updated by Luiz Souza about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

There is a new knob to enable the support and now it is enabled by default in pfSense.

Will be available on the next build.

Thanks.

#3 Updated by Nadav Rak about 2 years ago

Solved! Works for me, thanks!

#4 Updated by Renato Botelho about 2 years ago

  • Status changed from Feedback to Resolved

#5 Updated by Dmitry Ivanov about 1 year ago

same error (hn0: driver does not support altq) after upgrade to 2.4.4

#6 Updated by Nadav Rak about 1 year ago

I haven't upgraded yet. I think you should open a new bug report.

#7 Updated by Ben T about 1 year ago

altq regressed to broken in hyper-v in 2.4.4, but this is fixed already per this bug report:
https://redmine.pfsense.org/issues/8954

see the notes for a workaround in 2.4.4 while we wait for 2.4.4-p1

Also available in: Atom PDF