Project

General

Profile

Actions

Bug #8954

closed

hn0: driver does not support altq

Added by Dmitry Ivanov about 3 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
09/26/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4
Affected Architecture:

Description

hyper-v 2016
gen1 and gen2


Files

Actions #1

Updated by Jim Pingle about 3 years ago

  • Category set to Interfaces

See also: #7869

Actions #2

Updated by Arthur Hirstein about 3 years ago

Das gleiche Problem mit Hyper-V 2012, gen1

Actions #3

Updated by Steve Beaver about 3 years ago

  • Target version changed from 2.4.4-GS to 2.4.4-p1
Actions #4

Updated by Gustavo Mello about 3 years ago

Dmitry Ivanov wrote:

hyper-v 2016
gen1 and gen2

same here, using windows server 2016 on pfsense 2.4.4

Actions #5

Updated by Jon Gav about 3 years ago

Windows 10 Pro w/latest updates + Hyper-V.
2.4.3 was/is flawless. Upgraded to 2.4.4 and got this error and can't use Queue Status either

Actions #6

Updated by Dave Pone about 3 years ago

Having exactly the same issue. Fresh install of pfSense under Hyper-V on 2012R2.

Actions #7

Updated by Nadav Rak about 3 years ago

Actions #8

Updated by Steve Beaver about 3 years ago

  • Assignee set to Renato Botelho
Actions #9

Updated by Jon Gav about 3 years ago

hyper-v 2016
gen1 and gen2

Issue persistent in 2.4.5.development as well

Actions #10

Updated by Renato Botelho almost 3 years ago

Jon Gav wrote:

hyper-v 2016
gen1 and gen2

Issue persistent in 2.4.5.development as well

can you please run following command on your system and let me know the output?

sysctl -a | grep use_if_start
Actions #11

Updated by Renato Botelho almost 3 years ago

  • Status changed from New to In Progress
Actions #12

Updated by Ben T almost 3 years ago

On psense 2.4.4 running as vm gen2 on windows 10 build 1803 Hyper-V, the output of the command: (screenshot also attached)
sysctl -a | grep use_if_start
results in:

hw.hn.use_if_start: 0

edit: checked in 2.4.3, the result of the same command is: hw.hn.use_if_start: 1

Thanks @Renato Botelho for looking into this bug! It appears you are already narrowing in on the problem!

Actions #13

Updated by Renato Botelho almost 3 years ago

Ben T wrote:

On psense 2.4.4 running as vm gen2 on windows 10 build 1803 Hyper-V, the output of the command: (screenshot also attached)
sysctl -a | grep use_if_start
results in:

hw.hn.use_if_start: 0

edit: checked in 2.4.3, the result of the same command is: hw.hn.use_if_start: 1

Thanks @Renato Botelho for looking into this bug! It appears you are already narrowing in on the problem!

Please try to set it to 1 on System -> Advanced -> System Tunables and test to see if it helps

Actions #14

Updated by Ben T almost 3 years ago

I've created a new "System Tunable" with : hw.hn.use_if_start with value of 1 Then rebooted the VM.

Output of sysctl -a | grep use_if_start still results in hw.hn.use_if_start: 0

The error still appears when enabling the traffic shaper, or after a reboot with the traffic shaper enabled:
"There were error(s) loading the rules: pfctl: hn0: driver does not support altq - The line in question reads [0]: "

For anyone else troubleshooting this issue, you can test repro the original issue by installing pfsense 2.4.4 in a Hyper-V vm, with synthetic nics. Then in pfsense goto "Firewall" > Traffic Shaper -> Wizards -> traffic_shaper_wizard_multi_all.xml
> then just click next a bunch of times, the filter reload page will appear and show the error at the bottom of the output.

Actions #15

Updated by Renato Botelho almost 3 years ago

  • Status changed from In Progress to Feedback

I pushed a fix on FreeBSD-src. Please try next round of 2.4.5 snapshots

Actions #16

Updated by Ben T almost 3 years ago

The fix Renato pushed yesterday has fixed the issue! Traffic shaper starts up no problem now.

Looks like the first build with the fix is this one:

pfSense-CE-2.4.5-DEVELOPMENT-amd64-20181102-0213.iso

In this fixed build, the output of: sysctl -a |grep use_if_start results in:
hw.hn.use_if_start: 1

Thanks so much Renato for getting this addressed!

https://github.com/pfsense/FreeBSD-src/commit/82fb779f75798e0b3f8f048d7035c813edac52fc

Actions #17

Updated by Renato Botelho almost 3 years ago

  • Status changed from Feedback to Resolved
Actions #18

Updated by Ben T almost 3 years ago

In case anyone has already upgraded to 2.4.4 and wants to workaround the issue without waiting for a patch or downgrading back to 2.4.3, you can fix it via Loader Tunables. (see: https://www.netgate.com/docs/pfsense/book/config/advanced-tunables.html)

This is VERY dangerous for non-experienced users, proceed at your own risk! This is only if you are desperate to fix this problem in released version 2.4.4!

Goto the web interface of your 2.4.4 pfsense, click "Diagnostics" -> "Edit File"
For path, type: /boot/loader.conf
Click "Load"
Add this as a new line to the bottom of the file contents:

hw.hn.vf_transparent="0"

Click "Save"

Then reboot the PFSense, ALTQ will now work.

Thanks Renato for finding the root cause of this problem and getting it fixed upstream!

Actions #19

Updated by Greg M over 2 years ago

Hello!

This one is back in 2.5.0 snapshots.

Actions #20

Updated by Greg M over 2 years ago

Restored to 2.4.4-p3 and output is: hw.hn.use_if_start: 1
Clean install 2.5.0 snapshot: hw.hn.use_if_start: 0

Actions #21

Updated by Jim Pingle over 2 years ago

Please open a new issue with specific error messages and reference this one there.

Actions #22

Updated by Renato Botelho 9 months ago

  • Target version changed from 2.4.4-p1 to 2.5.0

Moving target to 2.5.0 since it regressed

Actions #23

Updated by Renato Botelho 9 months ago

  • Status changed from Resolved to Feedback

I've enabled hn_altq_enable option on default config. It was missing

I've also added needed loader tuning to installer to be configured by default on new installations.

It should be enough to cover this one

Actions #24

Updated by Greg M 9 months ago

Did upgrade and it works.

Actions #25

Updated by Renato Botelho 9 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF