Project

General

Profile

Actions

Bug #8051

closed

XG-2758 - Wrong Interface Assignment

Added by Clinton Cory about 4 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
11/03/2017
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

2.4.2-DEV CE (latest from an hour or so ago) installed on XG-2758 and the interfaces do not assign as expected.
https://www.netgate.com/docs/xg-2758/io-ports.html

WAN should be igb0 and LAN should be igb2 but the interfaces are assigned like this:
WAN -> igb0
LAN -> igb1

I have not been able to test this with the factory snapshot yet.

Actions #1

Updated by Clinton Cory about 4 years ago

Confirmed the same issue is present with 2.4.2 factory.

This was not a problem with 2.4.1

Actions #2

Updated by Clinton Cory over 2 years ago

  • Affected Version changed from 2.4.2 to 2.4.4-p3

Verified this is still different on 2.4.4-p3 CE

Actions #3

Updated by Jim Pingle over 2 years ago

  • Target version set to 2.5.0
  • Affected Version changed from 2.4.4-p3 to All

Looks like the 'RCC' model detection for mapping cards is not present in source:src/etc/inc/config.console.inc on CE. Factory is fine.

Actions #4

Updated by Jim Pingle over 2 years ago

  • Assignee set to Jim Pingle
Actions #5

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Not a Bug

Several models were only detected in Factory and setup with the correct NICs. I copied a few more CE-compatible devices over so they could be recognized.

Actions #6

Updated by Jim Pingle about 2 years ago

  • Status changed from Not a Bug to Feedback
Actions #7

Updated by Jim Pingle about 2 years ago

  • % Done changed from 0 to 100
Actions #8

Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.5.0 to 2.4.5
Actions #9

Updated by Chris Linstruth almost 2 years ago

Here's what I get with a recent 2.4.5 memstick ADI CE install:

Netgate XG-2758 - Serial: Redacted - Netgate Device ID: Redacted

  • Welcome to pfSense 2.4.5-DEVELOPMENT (amd64) on pfSense ***

    WAN (wan) -> igb0 -> v4/DHCP4: 172.16.1.163/26
    LAN (lan) -> igb2 -> v4: 192.168.1.1/24
    OPT1 (opt1) -> igb1 ->
    OPT2 (opt2) -> igb3 ->
    OPT3 (opt3) -> ix0 ->
    OPT4 (opt4) -> ix1 ->

Those match the I/O port docs.

Actions #10

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF