Project

General

Profile

Bug #8375

email session encryption fails in a private ca environment

Added by lists b over 1 year ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Notifications
Target version:
-
Start date:
03/17/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

when configuring email notifications, and enabling encryption, message notifications fail if the certificate provided by the server is signed by a ca other than those listed in /usr/local/share/certs/ca-root-nss.crt. this prevents use of a private/internal root ca.

please provide a mechanism for use of a private/internal root ca. this could be done similar to the auth/ldap server settings [system -> user manager -> authentication servers -> ldap server settings] system_authservers.php, or, imho, better by allowing augmentation of the system's root ca cert store [see feature #8373]

History

#1 Updated by Jim Pingle 2 months ago

  • Category set to Notifications
  • Status changed from New to Duplicate

Duplicate of #4068 and made optional in #9001

Also available in: Atom PDF