Project

General

Profile

Bug #878

Drag and Drop firewall rules causes corruption

Added by Warren Baker almost 10 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
09/06/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

As per forum issue http://forum.pfsense.org/index.php/topic,28037.0.html - re-ordering of the firewalls using drag-and-drop causes the rules to disappear/corrupted or duplicated.

I only see certain rules disappear when I try to move them around. It is simple to replicate by just creating a new rule and try drag it above an existing rule.
The odd thing is I also tested on IE8 and the same thing happened - so it doesn't appear to be a webkit issue.

Associated revisions

Revision a5ebdeff (diff)
Added by Erik Fonnesbeck over 9 years ago

Fix handling of floating rules in the drag and drop reordering code. Fix for part of ticket #878

Revision cb53651f (diff)
Added by Erik Fonnesbeck over 9 years ago

Small rework of code for applying drag and drop reordering of rules and some extra checks added to fix some potential bugs. Ticket #878

Also minimizes the extent of the changes performed (useful when comparing config.xml files from before and after).

History

#1 Updated by Warren Baker almost 10 years ago

Forgot to add that i tested with:

Chrome for Mac v5.0.375.127
Chrome for Windows7 v5.0.375.127 and IE8 v8.0.7600.16385

#2 Updated by Jesse Norell almost 10 years ago

Likewise with Chrome for Linux v5.0.375.127. Seems fine in IceWeasel 3.0.6.

#3 Updated by Chris Buechler almost 10 years ago

  • Target version set to 2.0
  • Affected Version set to 2.0

#4 Updated by Scott Ullrich over 9 years ago

I am having trouble replicating this problem in Chrome on Mac. Can someone else confirm?

#5 Updated by Chris Buechler over 9 years ago

I've had numerous reports of it in the past two months from talking to people. Click and drag around and you'll eventually get rules disappearing or numerous duplicates.

#6 Updated by Erik Fonnesbeck over 9 years ago

It is possible this is not a browser-specific issue, but actually caused by not handling floating rules correctly. Do you have any floating rules that reference the interface on which you were rearranging rules with drag-and-drop?

#7 Updated by Chris Buechler over 9 years ago

On one system where I personally encountered the duplicate (about 8 times duplicated) rules issue, there are no floating rules. I'm not sure about the other instances of the problem though.

#8 Updated by Warren Baker over 9 years ago

No this was all specific to the lan interface as I was testing on that. I didn't try setting up floating rules to see if there was a problem there.
However I have updated to the latest snapshot (Wed Nov 10 10:44:38 EST 2010) and I can't replicate the original problem.

I have, since the issue was logged, updated Chrome to v7.0.517.41 on both os x and windows and they both work. Safari v5.0.2 on both os x and windows also works.
Cant test with IE8 since i was a bit daft and upgraded it to IE9 beta which doesn't display the menu unless I turn on compatibility mode. If i do that I can't drag and drop anything - it just doesn't respond.

So I can reliably say I can't reproduce the issue.

I have just tested the floating rules and that allows allows me to drag the rules but they stay in their original position. So Erik I assume your fix will sort that problem out. Will test that.

#9 Updated by Erik Fonnesbeck over 9 years ago

  • Status changed from New to Feedback

I can't reproduce this in IE8 with the steps you mentioned, though I didn't try it there before making the changes. I think it should be fixed now, though.

#10 Updated by Scott Ullrich over 9 years ago

  • Status changed from Feedback to New
  • Target version changed from 2.0 to 2.1

I have disabled this feature. We will bring back in 2.1.

#11 Updated by Chris Buechler over 8 years ago

  • Target version deleted (2.1)

#12 Updated by Chris Buechler almost 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF