Project

General

Profile

Actions

Bug #8806

closed

HA sync : Starting captiveportal doesn't fire ipfw rules on slave, even if HA is enabled.

Added by A FL almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Captive Portal
Target version:
Start date:
08/19/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

When a CP zone is enabled, slave does not start the captive portal (despite "enabled" setting appear checked on the slave):
One workaround to this is to manually start captiveportal on the slave by clicking "submit" on the salve cp settings, or by rebooting the slave.

I think it would be better to automatically start the slave if captiveportal sync is ensabled in System-> High Avaliablity settings

Actions #1

Updated by Jim Pingle almost 4 years ago

  • Target version set to 2.4.4

I wonder if this might be the same root cause as #8721

An XMLRPC sync used to trigger filter_configure via XMLRPC which handled refreshing a number of things on the secondary after a sync. It doesn't now, which may be the cause of these issues.

Actions #2

Updated by Anonymous almost 4 years ago

  • Assignee set to Renato Botelho
Actions #3

Updated by Anonymous over 3 years ago

  • Priority changed from Normal to Normal-package
Actions #4

Updated by Anonymous over 3 years ago

  • Priority changed from Normal-package to Normal
Actions #5

Updated by Renato Botelho over 3 years ago

  • Status changed from New to In Progress
Actions #6

Updated by Renato Botelho over 3 years ago

  • Status changed from In Progress to Feedback
Actions #7

Updated by Renato Botelho over 3 years ago

  • % Done changed from 0 to 100
Actions #8

Updated by A FL over 3 years ago

Working correctly on the last snapshot

This issue can be marked as resolved.

Actions #9

Updated by Anonymous over 3 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF